Toshiba L30 sound problem... again

Hi I just installed openSUSE at my old Toshiba L30A-0100E.
And I’m actually really satisfied how everything works quite nicely out of the box… well almost everything.
Unfortunately the sound is not working i followed the suggestions in this entry and I could get some sound out off the speakers. But there is something still wrong. Mplayer plays the amarok test audiofile nicely but fails to terminate properly at the end so I have to stop it with ctrl-C. And amarok with the xine engine is totally unusable: you get only really distorted sound and it crashes totally.
I tried to upgrade to the newest alsa version with this 1-click-install but i have the same problem… and

cat /proc/asound/version

delivers only

Advanced Linux Sound Architecture Driver Version 1.0.16rc2

Can anybody help?
thanks a lot

I need to find out a lot of detail as to your configuration to come up with a recommendation. Reference your sound configuration, please, with your Toshiba L30 connected to the internet, please copy and paste the following into a gnome-terminal / konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal/konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a

Now, to get more information on your installed applications, please copy and paste the following into a gnome-terminal / konsole and post the output here:

rpm -q smplayer MPlayer amarok libxine1 libffmpeg0 w32codec-all xvid libquicktime0 mad vlc 

Also, are you using KDE4 or KDE-3.5.9 or Gnome or other desktop?

Sorry for answering so late, but i was over the weekend afk…

Here’s the link of the tsalsa script:
tsalsa.txt - (beta)

$ rpm -qa | grep alsa

$ rpm -qa | grep pulse

$ rpm -q libasound2

$ uname -a
Linux toshiba #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux

$ rpm -q smplayer MPlayer amarok libxine1 libffmpeg0 w32codec-all xvidlibquicktime0 mad vlc
package smplayer is not installed
package xvid is not installed
package libquicktime0 is not installed
package mad is not installed

to all this versions i have to tell u that i used the standard versions before but sound didn’t work either… so i updated

but as it looks like the kernel modules didnt get a update…(see my first comment) how to do this?

Im using the kde 4.1 on-click-install

thanks for helping

Thanks … I see ALC861. Looks like you put the model option “uniwill-m31” in your /etc/modprobe.d/sound file. Speaking of which, I should have asked for that. Can you copy and paste (and post here the output) of:
cat /etc/modprobe.d/sound

Now, reference the rest of your post

Once you get your sound working, you will have a codec problem, because you have the videolan libffmpeg installed instead of the packman libffmpeg installed. … see the “pm” in the version number of some of those apps. … that means they were packaged by packman … But lets get your sound fixed first, and worry about the codec later.

That is also my assessment. You are missing alsa-driver-default-kmp.

OK, for now, please stop using the one-click-install. And instead use the repositories that we will setup.

So please go here and setup your repositories for OSS, NON-OSS, Update and Packman and no others. If you have videolan as a repos, please remove it, as it has rpms that are not compatible with packman packaged rpms.
Repositories/11.0 - openSUSE-Community

Ok, now once that is setup, you need to address getting alsa updated properly. I am going to give you six zypper commands to send in sequence. The 1st 3 zypper commands are associated with updating your nominal alsa apps, and the 2nd 3 zypper commands are associated with updating your alsa driver. Its possible in the first group of 3 that you will be told the update is already in place. Send ALL of the commands anyway.

Do this by opening a gnome-terminal / konsole, and type “su” and enter your root password to get root permissions. Then copy and paste each zypper command, executing in sequence one line at a time, into the same gnome-terminal / konsole:

zypper ar multimedia
zypper install alsa alsa-devel alsa-oss alsa-utils alsa-plugins alsa-plugins-jack alsa-plugins-pulse alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia

zypper install alsa-driver-kmp-default
zypper rr multimedia

Then restart your PC.

It is quite likely it will NOT give you sound, because I susect “uniwill-m31” is the wrong model option for your toshiba. … Note the options for the ALC861 on your toshiba for 1.0.17 of alsa are:

	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack with SPDIF I/O
	  3stack-660	3-jack (for ALC660)
	  uniwill-m31	Uniwill M31 laptop
	  toshiba	Toshiba laptop support
	  asus		Asus laptop support
	  asus-laptop	ASUS F2/F3 laptops
	  auto		auto-config reading BIOS (default) 

Once you post the contents of your /etc/modprobe.d.sound file, I will make some specific recommendations on how to fix your /etc/modprobe.d/sound (that is if your sound is still not working).

ok all done…
and im using now the 1.0.18rc1 version of the alsa modules
unfortunately i’m still at the same point like the beginning:
I get sound, but totally chopped into pieces… and filled with repeatings and so on
my /etc/modprobe.d/sound contains this

#ALSA portion
alias char-major-116 snd

#OSS/Free portion
alias char-major-14 soundcore

options snd slots=snd-hda-intel
# 5Dex.kKlNW7EtbU7:IXP SB4x0 High Definition Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=uniwill-m31
#options snd-hda-intel model=toshiba

i actually changed to uniwill-m31 because like in my first post mentioned this was the only possibility to get at least some sound out of the notebook: Source: Another thread in this forum
also switching to various other models and passing no options at all didn’t do the trick, even worser i didn’t get any sound at all…
furthermore i get now this alsa-segfault after modprobing the new modules:

ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:617: hda_intel: azx_get_response timeout, switching to polling mode: lastcmd=0x000f0000
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:2503: hda_codec: model 'uniwill-m31' is selected
alsactl[3653]: segfault at 0 ip b7d28f83 sp bfa29e9c error 4 in[b7cb6000+13d000]

(whatever model i choose)


How about backing up that /etc/modprobe.d/sound file, and trying instead this simple /etc/modprobe.d/sound file:

options snd slots=snd-hda-intel
# 5Dex.kKlNW7EtbU7:IXP SB4x0 High Definition Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

and restart alsa with: su -c 'rcalsasound restart’and if that does not work, then replace “auto” with “toshiba” and restart alsa as noted above, and if that doesn’t work, try this /etc/modprobe.d/sound file instead:

options snd slots=snd-hda-intel
# 5Dex.kKlNW7EtbU7:IXP SB4x0 High Definition Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel position_fix=1 model=3stack 

and restart your alsa as noted above.

You could also try “position_fix=1” with the other alsa modules.

I was curious if you had an success in the end?