Toshiba issues

Installed 11.4-64 bit KDE on Toshiba U500 series notebook.
Really like most aspects except endless Toshiba related problems with power
management and thermal control.
Thought I had the fan issues under control on os11.3 with updated kernel and
acpi cheat codes; however, none of the codes seem to work on 11.4.
Basically problems are:
-None of fn or multi-media keys work
-No fan control as temperature varies
-Hibernate and Sleep do not work

Toshiba has apparently always had issues with fan control; however, I have not
seen this one before.
On first start of the day (unit is ‘stone cold’) fan does not start during boot
process and core temps are typically mid 40’s when unit gets fully booted. Temps
will continue to rise and fans will not start.

If I shutdown with temp 65C+ and immediately restart, fan comes on at high speed
as soon as rebooting begins and temps will be slightly lower when completely
booted. Fan will stay at high speed and temps go to low 40’s. Fan never slows.

If I again restart with temps indicated in 40’s, fan will start at low speed and
maintain temps in mid 40’s to 50’s during use.

Obviously fan speed is being set by temp measured at initial booting and not
adjusted thereafter.

I have tried various combinations of cheat codes (acpi.power_nocheck=1, nolapic,
nomodeset, acpi=Linux, acpi_osu=Linux) and none seem to have any effect.

“Sleep” does not work at all.
“Hibernate” almost works except could not re-establish wifi connection after
“Multimedia” keys do not work.

Apparently the latest kernel was to incorporate improved power management and thermal control but for my unit, the situation has unfortunately gone from ‘bad’ to ‘worse’

Hi Zuser, I seem to remember there being software specifically for Toshiba. A quick search in YaST including description shows omnibook kernel modules that seems to include what you need.

Hope that helps. Cheers!

On 03/16/2011 03:06 PM, zuser wrote:
> Toshiba U500 series notebook.

that is all good info (which i interpret as "do not buy Toshiba U500),
but it would be REAL nice if it were ‘captured’ in the Hardware
Compatibility List at

i guess the easiest way to do that is to use Smolt, which you can read
about in the middle column of

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Good suggestion and will do so if/when issues are resolved.

Good suggestion but unfortunately does not work.
I downloaded omnibook file and recompiled kernel with following results:

  • No help on fn keys
  • Multimedia keys now cause sliders to show on screen but no actual results, ie volume or muting
  • Original kernel no longer boots to graphic login, only cli.
  • Effects on thermal control appear to be ‘randomly mixed’. Have had two opportunities for cold boot and on both fan did not start during boot process and within 20 minutes of light use core temps increased to 80C+. On reboot, fan comes on at high speed and never slows even when temps drop to 39-40C.

I am most disappointed that 26.37 kernel with “improved thermal management” produces such results. Earlier kernel versions were also a problem with initial installs but at least grub cheat codes could be used to get acceptable performance. I am not too bothered by the issues with fn and multimedia keys but thermal issues are real irritating. Repeatedly rebooting while hoping to come on at the ‘right’ temp is a pain.

Just a quick FYI:

I’ve had terriible problems with thermal management on my two x205 Toshiba laptops with 11.0 - 11.2 (11.3 was so incompatible with several things on this particular model that I gave up on installing it.) With each of those versions I couldn’t find any real pattern to when the fans ran or didn’t run at any given speed. Overheating was frequently so bad that the systems often ran with temps in the 85-94 deg C range and occasionally crashed from overheating when the CPUs hit 100. I also tried a couple of different versions of Linux Mint to see if it was just an OpenSUSE issue, but the problem still existed.

For a long time I thought that the fans were damaged too, as they’d begun making horrendous noises when running at full speed. I bought four new fans to replace the old ones, however 11.4 M5 came along before the new fans got here.

I installed 11.4 M5 and eventually RC1 and then RC2 and now the final release. I still have the new fans in a drawer. The old ones are running fine on both systems, the strange noises are gone, and temps are now stable and well within a range of 47 - 56 deg 99% of the time.

I suspect that the thermal problems that plagued me were indeed fixed and very well in 11.4, but I also suspect that your newer U500 series laptop has a new set of Toshiba issues.

I’ve had six or seven Toshiba laptops over the years. The a85 and m45 series had no thermal issues for me, but after that… until 11.4 came along.

@zuser, Thanks for your post. You’ve reinforced my decision that my next laptop will be another brand.

Agree. The hardware is among the best but apparent indifference and lack of support for Linux is unacceptable.

I completely agree.