Tortoisehg not working after Tumbleweed update

After updating Tumbleweed yesterday Tortoisehg has stopped working. Nothing at all happens when trying to launch. There is no console output when trying to launch from the command line.

I’m using version 4.0-1.6 from ‘devel:tools:scm’ repo, I tried reinstalling and downgrading to 3.9-1.1 with the same result. Mercurial works just fine from the command line. Creating a new user (on KDE) account to test made no difference.

Has anyone else seen this? Without any output or hint as to what is going on I have no idea where to begin looking for a solution.

I’m seeing the same on Leap 42.2 using the same mercurial 4.1 with tortoisehg 4.0.2. My guess is that it’s a bug in thg…

Seeing the same thing lemmy04 is seeing. As plain user executing thg in the console shows nothing, but ‘sudo thg’ returns

thg: cannot connect to X server

. Running plasma 5, LEAP 42.2

Doing a distribution upgrade, using only the standard TW repos, solved the problem temporarily for me. But after updating again yesterday, the problem has returned. Given the Tortoisehg version did not change either time, since I have the devel:tools:scm repo disabled, this suggests the problem is not just with tortoisehg. I have not found any other reports of this problem with other distros, or just about thg itself, as far as I can make out the problem is just with openSUSE.

I just tried to downgrade to 3.9 again, and it too still fails.

Downgrading mercurial, from 4.1 to 4.0 (from seems to have fixed this for me.