torrent software won't work now

Hi, i’m running suse 11.1 and was trying to download two different peerguardian “like” programs, moblock and iplist. i downloaded the’s, but didn’t know how to install them, so i just deleted the files (i did unpack them in tmp).

Ok, so now, i notice that my monsoon wouldn’t start downloading a torrent. i removed monsoon and tried two different programs using ‘install software’. Both of them will open, accept the torrent, but then i just stay at 0 connection. I imagine that the incomplete/incorrect install/removal of moblock and/or iplist is the culprit. Neither moblock or iplist show on my installed software list in yast.

Try removing or re-naming the hidden folder for monsoon in in /home/username*

I don’t have monsoon but it’s probably .monsoon (re-name to .monsoon_old)

Then re-start monsoon.

If you use ktorrent or transmission or vuze, they all have IP Blocking plugins

i removed and reinstalled monsoon. i think maybe the port is being blocked. weird that it was fine yesterday before i started trying to install moblock and iplist. when i used xp, i used to be able to check if a port was open thru their console. i’ll look around online for something.

You can uninstall and re-install all you like, unless you remove the hidden files where all the settings are, I think you will have the same problem.

A Quick Bittorrent Guide (with screenshots) - openSUSE Forums

but would not removing the hidden folder in monsoon explain why other torrent programs aren’t being connected? i just turned off the firewall on my router and suse, and still no connection to torrents (download/upload/peers stay at zero)? i allowed updates to install this morning, and then i noticed the problem…connection?

You would have to re-set all the settings, that’s the whole point. Just re-enter all your ports in the torrent client and make sure you have those open in the firewall and forwarded in the router.

ok, i thought turning off the router and suse firewall would allow me to download something without opening ports, as i don’t know how to do that. I’ve never used a static ip and up until today,
the monsoon software worked fine.

right now, my router is set to no security, the firewall is disabled, and i’ve disabled the suse firewall. i still have to forward ports? i’ve looked online and everything seems to start with ‘first, establish a static ip address’. I even connected directly to my router, bypassing the wireless router completely, and the same problem exists. Does that mean that suse has no ports open?

It means you have no idea what you are doing:)
No offence, but the guide I posted should help you and there is a link there to Port Forwarding if you don’t understand that.

You should not be online with no router firewall. And you should leave the suse firewall ON, and just configure the ports there, as explained in the Howto.

now you’ve got it EXACTLY. can install OS, software, etc, but when it comes to port forwarding, never needed to. ok, i restarted my suse firewall and saw this:
Firewall Starting
• Enable firewall automatic starting
• Firewall starts after the configuration gets written

Internal Zone
• No interfaces assigned to this zone.
Demilitarized Zone
• No interfaces assigned to this zone.
External Zone
• eth0
• PRO/Wireless 2200BG [Calexico2] Network Connection / eth1
• ‘any’ Any unassigned interface will be assigned to this zone.
Open Services, Ports, and Protocols
• Zone has no open ports.

the “zone has no open ports” part makes me wonder. i’ll work through the guide. thanks.

ok, went through the guide. i downloaded and installed azureus/vuze, as this is the client i’m most familiar with. i configured suse firewall and my router as described. the only part that i didn’t do was to set up a static ip. there were no directions for linux on the ‘port forwarding’ site, so i googled ‘set up static ip suse’ and looked at a few of those. i did ifconfig command and got my address that way and used it.

i’m now downloading at good speeds. i suppose if my isp changes my ip address (don’t they do that occasionally), i’ll have to either learn how to set mine up as static or just re-enter the new one.

thanks for your help, and thanks for placing a smiley face after informing me that i know nothing about port forwarding. it’s true, but i’ve found that if we add a smiley face when pointing out another’s fault, it is received much better! :slight_smile:

Oh, by the way, suse firewall is running and the ports are shown in the ‘summary’ when i close it. my router firewall is running too. and everything works!

The actual IP from your ISP can either be static or dynamic. And it should not matter either way. The only IP addresses you need be concerned about usually are the LAN IP’s. That is the IP assigned to your network on the LAN.

Good to hear it improved for you anyway:)