Tor won't start at boot openSUSE 12.3

So I’ve installed tor from through YaST. I can run tor and use it without a hitch. However I have trouble getting it to load from boot. I have tried the following methods:

  1. YaST -> System Services (Runlevel) -> Enable tor

  2. In terminal, sudo chkconfig tor on

The YaST method doesn’t work and gives me the error message “/bin/systemctl start tor.service returned 1 (unspecified error):”, and the second method doesn’t give me an error, but on reboot, tor fails to load by itself.

I’ve tried looking through the tor bug tickets and by googling this issue, but I can’t seem to find anything. I used tor flawlessly on 12.2 and had no issues getting it to start at boot. Anyone else experiencing this?

Perhaps its the switch to systemd for openSUSE 12.3 that keeps it from working? i do find a service file in openSUSE 13.1 as tor has been upgraded. I have a bash script for systemd you can find here:

SysdCmd - systemd Command Help/Config Editor - Blogs - openSUSE Forums

Thank You,

I’m somewhat confused, how does this help with my situation? I ran your script, I’m still lost on how to solve this issue.

So I don’t use tor, but you do. Perhaps there is no systemd service file to start or you need to find out how to start the service file for tor. That means you need to look into systemd as being the issue perhaps. I have no drop in solution for tor, but anyone could provide one if they have heard of the problem before. I do see that tor has been updated to work with systemd in openSUSE 13.1 which may be your next move in just a few more days when released. The bottom line is you need to investigate the package issue and that I do not have a known fix for this application at hand, only an idea of what might be the problem.

Thank You,

I don’t use 12.3, but a tor*.rpm installs the needed files including /etc/tor/torrc. This file must be edited usually because the default install doesn’t run as a daemon.

the line:

#RunAsDaemon 1

should be changed eliminating the # to:

RunAsDaemon 1

after edit, starting the service in yast2 should work, then reboot and you should see it there all the time.

good luck.

Solved my problem, thanks!