Tor + FoxyProxy

I installed tor, but when I tried to run it:
/etc/rc.d/tor start
it complained that there was no /etc/tor/torrc
I made this file, (copied from torrc.sample) and now it runs but FoxyProxy still refuses to work. It says that servers are taking too long to respond. I don’t want to use privoxy, how can I get just tor working with FoxyProxy???


Alright, got tor working (with no changes actually, it just decided to work this time). How can I add the tor daemon into the system startup? I searched for /etc/rc.local (what I’m used to) but that’s non-existant in openSUSE. Any ideas?

Shameless bump.

Thread moved to Network/Internet

I’ve been faked out sooo many times thinking I have a response to my thread when really I’ve just been told that the thread has been moved. :slight_smile:

Is this what you are looking for?

“Control Center” -> “System” -> “Session Preferences” -> “Add”

Huh. Could be, I don’t have that though, I’ve got System Services (Runlevel). That’s the closest wording I have to ‘Session Preferences’
I have tor listed in the runlevel preferences but when I click ‘Enable’ it says that tor isn’t running. I got it to work once like this but the Control Center crashed. Perhaps I just need to reboot but I just did an update and ~5 KDE packages couldn’t be located so I’m scared to reboot/logout until I get em for fear that I have a broken system! :wink: One step at a time, one step at a time hehe

Apologies:(, I should have checked whether you were using Gnome, which I am. I do not know where to look in KDE, but you should have something akin to “Session” somewhere?

No worries! I know how to do it in GNOME as well, it’s fairly easy! hehe KDE, not so sure.

Thanks for your help!