Нужна помощь рускоговорящих разработчиков

Установил KDE 4.5.2 из этого репозитория

Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.3

на opensuse 11.3 до неданего времени было все замечательно, тут выяснилось что при попытке проиграть .mpeg или .wmv файлы падает Kaffeine

https://bugzilla.novell.com/show_bug.cgi?id=646921

Dr. Konqi найти нужные debag пакеты не смог добавил еще пару репозитариев и теперь при попытке доустановить пакеты через интерфейск Dr. Konqi падает Dolphin

https://bugzilla.novell.com/show_bug.cgi?id=646909

Так как у меня не совсем хорошо с английским то я боюсь что англоговорящие разработчики меня не поймут, поэтому хочу попросить прорецензировать мой багрепорт и если есть возможность подправить.

Былоб неплохо еслиб указали откуда доставить нехватающих debag пакетов чтоб crash репорт был полный

Спасибо!

Debuginfo и debugsource ставятся ы того-же репозитария.

Например для кафеина http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_11.3/i586/kaffeine-debuginfo-1.1-27.4.i586.rpm


sudo zypper in -r <repo> kaffeine-debuginfo kaffeine-debugsource

Баги от последнего KDE лучше конечно в bugs.kde.org постить. Там помогут быстрее и лучше, и предпримут что-то тоже быстрее. В новелловскую багзиллу все же лучше только о том, что так или иначе свойственно только oS.

rpm -ihv http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_11.3/i586/kaffeine-debuginfo-1.1-27.4.i586.rpm

Debuginfo и debugsource ставятся ы того-же репозитария.

Например для кафеина http://download.opensuse.org/reposit…-27.4.i586.rpm

Подозреваю что был какой-то глюк с репозиториями, попробую еще раз установить, спасибо!

На баг с Dolphin мне уже ответили сказали что баг известный и это баг со стороны D-Bus посоветовали обновиться до 1.3.1 или старше

------- Comment #1 From Peter Penz 2010-10-15 10:36:02 -------

Thanks for the bug report! This is an issue in the D-Bus library which
has been reported already. It is fixed in D-Bus 1.3.1 and later:

#QTBUG-7475] send_with_reply_and_block in libdbus is not thread-safe - Qt Bug Tracker](http://bugreports.qt.nokia.com/browse/QTBUG-7475)
https://bugs.freedesktop.org/show_bug.cgi?id=17754

If you cannot update to D-Bus 1.3.1 or later, you can disable tool tips and the
Information Panel as a workaround.

https://bugs.kde.org/show_bug.cgi?id=254237

Самое интересное что OpenSUSE 11.3 D-Bus 1.4.0 WTF??0_о

И да, у меня libxine1 с кодеками установлен из пакмена, может в пакмене его криво собрали?! Как это можно проверить?

Оставьте комментарий в bugzilla что верся dbus у вас 1.4.0

Ошибся, версия D-Bus 1.2.24 ((( Обновлений D-Bus не предвидится?

Thiago Macieira 2010-06-22 05:55:22 PDT

Patch reverted with e40c45fb4635321f17f3d6e4f9a4566fb62b3623

Comment 17 rwman 2010-06-23 01:38:36 PDT

Ok, but will Havoc’s patch make its way to 1.3 ?

Comment 18 Thiago Macieira 2010-06-23 03:21:05 PDT

Yes.

I’m running the patch for a few days in my own computer under real-life
situations to see if there are problems. Then I’ll push it to 1.3.

Comment 19 Thiago Macieira 2010-07-01 03:24:19 PDT

Fix is committed as 6ff1d079316cb730a54b4e0e95bd3e6e31f439de
(dbus-1.3.1-2-g6ff1d07)

https://bugs.freedesktop.org/show_bug.cgi?id=17754

Хе-хе. Там их и похоронят благополучно. Свистоперделки гораздо важнее исправления багов.

Чтобы не быть голословным, пара ссылок:

https://bugs.kde.org/show_bug.cgi?id=174977

https://bugs.kde.org/show_bug.cgi?id=35371

Comment #52 From aphidia hotmail com 2010-09-03 22:29:31 -------
HAHA, I just noticed this bug today and it’s been 10 years!!

Могу ещё десяток накидать.

Вот поэтому я думаю надо багрепорт дублировать в основую багзиллу и ив багзиллу дистребутива, разрабочик основной ветки птица годрая пока мейнтейнер дистребутива не пнет фиксить баги вместо написания свистоперделок не начнет.:slight_smile: Покрайней мере для ДЕ разрабов это справедливо :smiley: