Too slow: how to improve?

Using 64-bits openSuSE 11.0, it seems slower compared to Linux Mint. I especially notice a bit more hard disk activity and slower response.

System:
Intel Core 2 Duo @ 2.1Ghz
2GB RAM
160GB HD

I installed with the automations and suggested setup, so I got 2GB of swap. I was thinking of enlarging this swap partition/file to about 3.5GB. Is it wise or foolish to do so? And if I do so, should I use Gparted and how exactly?

Thanks for the coming answers.

IMHO, increasing the swap won’t do anything. Disable/remove anything to do with beagle, disable any services you don’t need

Andy

@deltaflyer is exactly correct. Unless there is dramatic degradation, which would indicate something seriously amiss, the difference will be in what is installed and how it is configured. openSUSE includes services that are not included in Mint; take a look at YaST Runlevel to see some of these. Are the Desktop Environments the same, and set up the same? As already mentioned, is Beagle running? Etc.

You can take a look in Ksysguard at whether/how much swap is being used. With 2GB RAM, there shouldn’t be much. If you add more swap, that won’t help. However, if there is a lot going into swap, that can indicate an issue - something is using up the RAM. Take a look at Ksysguard’s System Load RAM sheet. What you care about is that portion which is “Application”; the “Cache” is just data that gets held for reuse but is flushed on demand. If Applications are taking all of the RAM, data will need to be cached to swap and that will degrade performance. In that case you want to look at the Process Table to determine what apps are hogging all the RAM (i.e., the Memory column), and investigate why.

Interesting observation, I myself find that when compared to Fedora and Ubuntu, Opensuse whether 32 bit or 64 bit is less responsive and has more hd activity going on.

I have tried a few things to improve the situation, from disabling services that are not required, tweaking the kernel, and i never install beagle.

But at the end of that, Fedora and Ubuntu are still more responsive and hd activity is lower.

If you’re sure you’ve removed beagle then I’d suggest looking in the /etc/sysconfig editor under YaST and disabling the ‘locate’ and ‘mandb’ stuff, which also cause bursts of disk activity at inappropriate times.

BTW, you’ve “tried things”. Did you speculate about the possible culprit, or did you measure e.g. CPU usage using top? I fully agree with mingus725 - it’s necessary to isolate the problem methodically.

Thanks for the responses.

I’ve totally deinstalled Beagle and its related stuff to my knowledge, and it seems a bit more responsive now, but not enough. For example, typing something into the opened Run Program window (Alt+F1/F2) usually stalls a bit, but after a while, after startup, the system gets faster. I checked the Runlevel, but as far as I know on first sight it looks okay.

I can’t seem to find this Ksysguard. Where is it located?

I might just try a few other Linux distros, since my machine isn’t really fully used for the time being anyway. It’s just that I kind of got used to openSuSE and have gotten a warm place for it in my heart, even though it’s been only a day or two :stuck_out_tongue:

try using the command line tool called top

open terminal

top

let run for a few secs and see which processes stay @ the top of the list when you are working.

some stuff that takes a lot power is desktop effects, if you don’t have a lot of memory (<=1024mb) or a powerful graphics card, turn them off.

turn off unnecessary processes

What do you mean by ‘slow’?

I’ve used Fedora over a year ago and used Ubuntu for the last year and I find openSUSE11 not slow at all in the week I’ve been using it.

First I ran OS11 as live CD on a new laptop with 4GB ram and it flew. Then I installed OS11 on my old 400Mhz Pent2 with 384MB ram and it still is pretty quick considering this P2 is 11 years old.

The only lag I had was when online. This turned out to be an ‘IPv6 issue’ (had the same lag with Ubuntu) but when I disabled the IPv6, OS11 took off and is just as fast as Ubuntu.

FWIW

Here’s that IPv6 link.

What Ive found is that once Im safely logged in and sitting in X the system runs quite happily (running on a dual core 1.5ghz laptop, 1 1/2 gb ram and on-board graphics) but the startup can be a nightmare, with it taking 4 minutes from pushing the power button to getting in.
This is of course exceptionally longer than the likes of Ubuntu and Slackware which both get into X in about 2 minutes. Using Gnome for both openSUSE and Ubuntu, Fluxbox on Slackware.

Does anyone have any tips for cutting down the boot time?

Take a look at dmesg, the kernel boot log, and the system messages log. Sounds like there is something taking an inordinate amount of time. It may be that you need to add a module to your initrd, or disable a non-applicable service, or change a configuration. We have 5 machines running SuSE, a couple no more powered than yours, and all our boot times are no more than 2 minutes.

The synapses are a bit soggy tonight, so I can’t quite remember.

But, isn’t there a page out there where someone listed all common processes and why or whether you needed them? The guy recommended which you could turn off and suggested more.

…maybe that was Windows…?