Too many password prompts on login

Currently when I log in to openSUSE I have so many password prompts coming up it’s a massive bother.

I have a PGP key password request, the kwallet password request, rsa password from ksshaskpass and my wireless network password

I understand that you can chain these together so that you don’t need to input each password but just one. But I don’t see a way to do it.

The kwallet password request only started to come up when I changed my account password, but now I am not able to get rid of it, I read a post which stated that you could move the kwl file away and the next time you log in it should go away, but instead it came back asking for the old password still. Is there any way to stop this? Also, I have noticed that when this prompt comes up I am unable to type in any other text fields until I have either cancelled it off or entered the password.

The wireless key is locked with my PGP key, I know because if I cancel that one, then enter the password for the PGP key it will let me join the network without asking again. Is there a way to ensure it defers asking me and waits for me to put in my password?

It’s hard to know what causes this, without knowing which programs are automatically started.

One way to avoid the WiFi network prompt, is to edit the connection and set it to be shared with all users. When you do that, then NetworkManager remembers the key in its own configuration and the network is started even before you login.

For the “ksshaskpass” prompt, there’s a box that you can check, to remember the key. If you do that, the key is saved in “kwallet”, so you should only be prompted for the “kwallet” key.

Thanks for the input, the only thing I have configured to autostart is ksshaskpass, by adding the following script to ~/.kde4/Autostart:

export SSH_ASKPASS=/usr/lib/ssh/ksshaskpass
/usr/bin/ssh-add </dev/null

I have tried selecting remember password, but it still comes up each time I log in requesting the password along with all the other password requests.

With regards to allowing connections to be shared by all users, I’m willing to try this, but I don’t see where to do what you described. I don’t see a program called NetworkManager, I also can’t see anything to do this in YaST or System Settings, right clicking on the network in the system tray icon menu brings up a “Network Management Setting” dialogue, but I don’t see any way to configure network sharing here either, can you advise where to do this?

I run the ssh manually. In my experience, if I do that too early, then “kwallet” doesn’t seem to be ready yet, so the request to get the password from kwallet times out and I am prompted for the passphrase.

Maybe try replacing that last line with:

        sleep 20
        /usr/bin/ssh-add </dev/null
)  &

That puts the passphrase request into a subshell, with a 20 second delay. The “&” allows the main autostart script to complete, so that nothing else in KDE is waiting for it. Note that I have not tested this. Change the “20” as needed. For a slow computer, you might need longer.

With regards to allowing connections to be shared by all users, I’m willing to try this, but I don’t see where to do what you described.

Click on the network icon in the tray (left-click, not right click). That should bring up a window showing your connection. Then click on the tool icon near the top right. That should get you into the connection editor.

Thanks this seems to have stopped both coming up, although I did have to increase it to 60s, and even then the first time it didn’t work (even on a i7-5600U) so I may increase further to 90s just to be safe!

Not sure whether it was this one that helped, or whether I did something else without realising but now I no longer get the key chain password request on logging in.

YES thank you, that seems to have solved the issue!