TOMOYO bei mir problematisch

Habe seit gestern mit TOMOYO gearbeitet, um mein Systen zu härten, der Sicherheit wegen. Nachdem ich die TOMOYO-PROFILE im LEARNING-MODE gespeichert hatte, meldete der SuSE 12.1 Kernel Fehler beim Hochfahren. Daraufhin habe ich TOMOYO aus der Bootoption wieder harausgenommen. Danach funktioniert gar nichts mehr. Zum Glück hatte ich mit CLONZILLA ein IMAGE der LINUX-PARTION gezogen, die ich dann wieder problemlos aufspielen konnte. Hat jemand Erfahrung mit TOMOYO und könnte mir sagen, was ich falsch gemacht habe?

Es ist leider umöglich etwas darüber auszusagen. “Der Kernel meldete Fehler”. Aber welche? Hast du AppArmor deaktiviert? Dies geht mit einem Kernelbefehl den du am Anfang in Grub angeben musst:

apparmor=0 security=TOMOYO

Ich nehme an du hast dich gut dokumentiert bevor du losgelegt hast. Dazu gehört auch das du hier klar angibst welche Version TOMOYOs du benutzt hast. 2.5 (im Kernel integriert und nicht mit gleichzeitigem Betrieb von Apparmor zu verwenden - jedenfalls noch nicht) und Installation der rpm Pakete des TOMOYO sites. Oder war es 1.8.x das mit gleichzeitigem Ausführen von AA kompatibel ist aber schwieriger zu installieren? Vom sourcecode compiliert und den Kernel gepatcht? So wie du im Moment fragst, und mit den wenigen Infos die du gibst ist keine Antwort möglich.

  • War das system 32bit oder 64?
  • Welchem HOW TO bist du gefolgt?
  • Wie genau war der Fehler der ausgegeben wurde
  • Startete das System mit dem/den Fehler(n) oder nicht?
  • Startete X?
  • Wenn nicht, in welchem runlevel hielt das System an?
  • Benutztes du systemv und init scripts oder systemd?
  • Welche Repos hast du aktiviert?
  • Welchen Kernel hast du benützt?
  • Ist dies ein regulärer Systemkernel oder ein selbst kompilierter mit SAKC?
  • Oder gar ganz in Handarbeit?
  • Waren die Kernelsources installiert? Hast du alle Abhängigkeiten geprüft vor der Installation und mit deinem System abgeglichen?

Wenn du Antworten willst musst du deine Frage gut stellen.

[li]War das system 32bit oder 64? 64 Bit
[/li][li]Welchem HOW TO bist du gefolgt? TOMOYO LINUX 2.4.x: The Official Guide
[/li][li]Wie genau war der Fehler der ausgegeben wurde Kernelmeldung
[/li][li]Startete das System mit dem/den Fehler(n) oder nicht? Der Kernel meldete den Fehler: zu viel ACLs!
[/li][li]Startete X? Ja
[/li][li]Wenn nicht, in welchem runlevel hielt das System an?
[/li][li]Benutztes du systemv und init scripts oder systemd? systemd
[/li][li]Welche Repos hast du aktiviert? 12.1: spins, server, security, distribution, repo/oss, repo/non-oss, debug/update, debug/distribution, tumbleweed, education, games, rmp/stable, KDE3, KDE/47,
[/li]GNOME:Apps, Packman
[li]Welchen Kernel hast du benützt? Linux 3.1.9-1.4-desktop x86_64
[/li][li]Ist dies ein regulärer Systemkernel oder ein selbst kompilierter mit SAKC? Regulär
[/li][li]Oder gar ganz in Handarbeit? Nein
[/li][li]Waren die Kernelsources installiert? Hast du alle Abhängigkeiten geprüft vor der Installation und mit deinem System abgeglichen? Weiß es nicht!
[/li][/LIST]
Wenn du Antworten willst musst du deine Frage gut stellen.[/QUOTE]

Habe AppMon nicht abschalten müssen, das wurde automatisch getan, nachdem ich die Bootoption security=tomoyo eingetragen habe. Die Fragen habe ich in deinem Reply beantwortet. Ich habe nachdem ich den Learning Modus eingeschaltet und das Policy File gesichert habe mit tomoyo-savepolicy beim nächsten Reboot eine Fehlermeldung aus dem Kernel bekommen: too many ACLs. Diese Fehlermeldung hat sich wiederholt. Dann habe ich über den bootloader die security=tomoyo Option herausgenommen und neu geboot. Ich bin in einer Terminalsession gelandet. Nachdem ich mich dann unter root einloggte, hatte ich keine Berechtigung mehr, ls, cat reboot oder andere Kommandos auszuführen auszuführen.

Du kannst nicht einfach die option security=tomoyo “herausnehmen”. Du musst einen Parameter zum deaktivieren stellen, steht AFAIK in den FAQs von TOMOYO.
Ubrigens ist AppArmor nicht AppMon. Du mußt den Parameter setzen. Sonst gibt es eine Fehlermeldung.
AppArmor
AppMon
Also denke ich das du den AppArmor=0 parameter setzen mußt.
Too many ACLs:
TOMOYO Linux users mailing list (English)
Du mußt also di policy correct setzen und wildcards benutzen. Du kannst außerdem die quota als Wert selbst hochsetzen. Quota exceeded…nicht war?
So wie ich das sehe, brauchtest du das System gar nicht zurücksetzen sondern nur die FAQs con TOMOYO lesen und ca 5 sec. auf Google suchen. Dann bekam ich schon dieses Resultat. :wink:
Übrigens ist AppArmor funktionell wenn du auf SystemV umstellst. Dann brauchst du eigentlich TOMOYO nicht. Wenn du TOMOYO magst wegen der guten learn policy must du aber das berühmte Manual lesen](http://tomoyo.sourceforge.jp/2.5/index.html.en). Ganz ohne geht es also nicht. Da steht dann auch alles über ACLs.

Danke für die schnelle Hilfe. Habe wohl nur das Video angeschaut und gedacht, dass dies schon alles wäre.

Kein Problem, übrigens, wenn ich mich richtig erinnere benutzt du FTP. Man sollte sowieso wenn möglich SFTP benutzen, und der letzte Punkt des links mit dem Manual geht genau darauf ein. Das kannst du dann auch vertiefen.
Gruß.