tomcat55 will not start

Hi there,
Installed tomcat55 through Yast - Software Management off the SuSe 10.3 DVD. Would like to run it as non-root user so changed ownership using chown but get following when I try to start the server:
simon@suse:/usr/share/tomcat55/bin> ./startup.sh
Using CATALINA_BASE: /usr/share/tomcat55
Using CATALINA_HOME: /usr/share/tomcat55
Using CATALINA_TMPDIR: /usr/share/tomcat55/temp
Using JRE_HOME: /usr/lib/jvm/java/jre
/usr/share/tomcat55/bin/catalina.sh: line 330: /var/run/tomcat55.pid: Permission denied

I’m a relative newbie and don’t understand this so would appreciate any help. I tried running it as root and I think the server starts but when I point my browser at http://localhost:8080/ I get a blank page?

Regards,
Simon

Don’t use start.sh. Use:

/etc/init.d/tomcat start

(might be tomcat5 or tomcat55 above)

Or enable it to start at boot using YaST > System > Runlevel editor

Thank you, tomcat is now running. The ‘permission denied’ i got around by changing ownership of /run. I’m sure there is a security issue here and probably a better way to do it. Perhaps I should leave ownership as root and run it as root?
The blank page was solved by installing the tomcat sample webapps which I had neglected to do!!

Simon

I think the correct ownership of the run directory should be tomcat as the init script switches user id to tomcat when it starts the service. But I can’t swear to it as it’s been a while since I ran tomcat. You could run

rpm -V tomcat55

to see if you have messed up the ownership of the run directory by running start.sh by hand as root the first time.