Today's Knetworkmanager update not working

hello all,

after updating knetworkmanager today (and it’s dependant pkgs), it won’t launch anymore. I’ve attached the screencap of the DBUS error it throws.

here’s the repos I’m running:

>zypper lr -Ppu
#  | Alias                               | Name                       | Enabled | Refresh | Priority | URI                                                                                              
6  | Packman                             | Packman                    | Yes     | Yes     |   90     |                                                          
7  |       | OSBS:Mozilla               | Yes     | Yes     |   94     |                                 
3  | KDE:Factory:11.2                    | KDE:Factory:11.2           | Yes     | Yes     |   95     |              
4  | KDE:Factory:11.2:Community          | KDE:Factory:11.2:Community | Yes     | Yes     |   95     |
1  | 11.2-security                       | 11.2:Secruity              | Yes     | Yes     |   96     |                                 
5  | Lazy-Kent                           | Lazy-Kent                  | Yes     | Yes     |   96     |                         
2  | KDE:Backports                       | KDE:Backports              | Yes     | Yes     |   97     |                        
8  | | 11.2:Updates               | Yes     | Yes     |   99     |                                                        
9  | libdvdcss                           | libdvdcss                  | No      | No      |   99     |                                                          
10 | repo-debug                          | openSUSE-11.2-Debug        | No      | No      |   99     |                                   
11 | repo-non-oss                        | 11.2:Non-Oss               | Yes     | Yes     |   99     |                                     
12 | repo-oss                            | 11.2:Oss                   | Yes     | Yes     |   99     |                                         
13 | repo-source                         | openSUSE-11.2-Source       | No      | No      |   99     |                                  

The update that borked came from KDE:Factory:11.2. Rolling back to the knetworkmanager in KDE:Backports does work, however it does not launch automatically at login.

I’ve already alerted the devs:

Follow that thread for a workaround

Thanks, and well said.

The alternative was to use ifup which you can switch to in Yast - Network Settings - Global settings and put the dot at “Traditional Method with ifup” (instead of “User Controlled with NetworkManager”

No need to go ‘ifup’, it’s simply not handy on a laptop. Install WICD, it’s found here: , search for wicd. Start WICD-client and you will be able to WeiFei to the world :wink:

I guess my problem was much worse, but I did not explain completely. As I attempted to find out what was wrong, I rebooted and had no working network connection - until I switched to ifup in YAST. Without a working network connection I’m sure you can understand I had no ability to install or re-install/revert anything; I was left with whatever network I could resurrect using what tools were already available and installed. Much panic ensued until I remembered what I hoped must still be part of my install : if(up/config/down) etc. Curiously in the middle of all this Kontact would not give me an error when checking for email it just said no new messages. It was clear that I had an ip address after running ifup and ifconfig from the console, but until I enabled ifup in YAST there was no browsing or email. Cheers

Ok, had this & followed the instructions which fixed it. Now how do I get knetworkmanager to start at login again?

The most beautiful hack was in the thread we were both in about starting knetworkmanager :wink: We want it to start right away, don’t we, not as a last item after kopete, skype etc ?
Edit /usr/bin/startkde and add “+knetworkmanager” to the LD_BIND_NOW line :wink:

AFAIK the normal way is to start it from the menu or a terminal, then logout and back in again. Mind, Networkmanager has to be the method configured in Yast.

Yeah, that quick little hack was great :slight_smile: Was working nicely until I got the update mentioned above.

To fix it I did:

I configured via yast to use ifup, and plugged in an ethernet cable (I couldn’t figure out how to set up a connection for a wireless card in yast…).

I followed the instructions in the post above regarding creating the .conf file.

I set networking back to networkmanager in yast, unplugged my cable & started knetworkmanager from alt+f2. Worked & connected to wifi & cable too.

Log out, log in: knetworkmanager does not start, alt+f2 will start it with no errors & it connects. Reboot & log in: no knetworkmanager :frowning: starts with alt+f2 or in konsole just fine.

The hack we found in the other thread is still active here as well (+knetworkmanager).

I did change some settings in yast when configured for ifup (iirc, I changed the cable to be ‘on cable connection’ from ‘auto at boot’) when I was looking to try and configure a wireless connection (essid, password etc).

Somehow I have managed to bork the automatic starting of knetworkmanager, was wondering if there is some tickbox somewhere that says start automatically at login?

I have it working again - there is a little tickbox in networkmanagers optios that says ‘show tray icon’ - it was unticked so I ticked it & it now starts at login :slight_smile:

All back working again, thanks.