To realize network sharing with HP printer,but the result of printing is abnormal

Release 11.3
GNOME 2.30.0

The printer(HP-LaserJet-P2055d with driver hpijs3.10.2 ) is connected with one host computer in our office room,sharing with CUPS Server(IPP).I’m client.The problem is as following:
every printing with additonal paper printing :"***Warining: GenericResourceDir doesn’t point to a valid resource directory", and there is a line of messy code below each page. I’m gloomy for a long time, please help me out !
Thanks !

I’ve never seen this error reported previously. Nevertheless, a bit of googling led me to this bug report:

https://bugzilla.novell.com/show_bug.cgi?id=633468

It’s a bit cryptic (I only skim read it), but it did refer to the hpijs driver foomatic-rip-hplip filter. Here’s an upstream HP bug report.

Anyway, a bit of left field thinking, I think you could side-step this issue by using the hplip driver:

HP Linux Imaging and Printing

Delete your existing printer config on the client machine, and reconfigure using

su -c hp-setup

Follow the prompts given. Hope this works for you. :slight_smile:

firstly,thank you very much for your help.
I follow your advice and try to install HP Linux Imaging and Printing,but encountered new problem.
After restart pc,no devices found with “error: No devices found on bus: usb”.
I think my system need a libusb package,but after Commad Line “zypper in libusb”,noting to do.
So please tell me what I should do next?

I follow your advice and try to install HP Linux Imaging and Printing,but encountered new problem.

I’m not sure where you have got stuck. Did hplip install ok? Did you install the .run file from via the HP site, or did you install a RPM package via the standard openSUSE repos?

zypper in hplip

Did you get as far as configuring via hp-setup? Was that when you encountered the error?

Running ‘hp-check’ can be useful to determine what might be failing, or missing etc
If you installed via tarball or .run file, then

hp-check -c

For RPM install, use

hp-check -r

BTW, you’ll get the error

Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

if you try to run ‘hp-setup’ as regular user, and you’re not a member of the ‘lp’ group.

Assuming you ran it with root privileges (as I outlined previously), then this error would also occur if no usb printer was connected (as expected). Now, since you mentioned you have a network connected printer, you need to make you select ‘Network/Ethernet/Wireless’ option when hp-setup is started. You also need to make sure that the printer (and host machine) are connected obviously.

I installed .run file via HP site.
Now ,after "hp-check -c " command ,“HP Linux Imaging and Printing System (ver. 3.11.10)
Dependency/Version Check Utility ver. 14.3” come out .
I think it’s ok.But when Checking for CUPS,there is a warnin :/etc/cups/cupsd.conf file not found or not accessible.
Then I follow “su -c hp-setup” command , select ‘Network/Ethernet/Wireless’ option, but my hp printer could not be found.
Later,I used YaST2 and seted printer cups server(IPP),added a network printer.Pleasantly,the problem previously disappear. No warning page, no messy code.
However,the nightmare isn’t over.The word content is not printed correctly ,the printed text is a little close to upside margin ,to cause some line missed.Headache!

Then I follow “su -c hp-setup” command , select ‘Network/Ethernet/Wireless’ option, but my hp printer could not be found.

Yes, as explained previously, you need root privileges for hp-setup to configure your printer. There is an option to configure manually - ‘Show Advanced Options’ >> ‘Manual Discovery’. There is an option to enter the IP address or network name as required. Anyway, it looks like the YaST tool has done the job for you.

The word content is not printed correctly ,the printed text is a little close to upside margin ,to cause some line missed.Headache!

What application were you printing from? What type of document? Was it a web page in firefox you were trying to print for example? Some applications, such as kwrite, allow the print margin to be set at print time.

FWIW, the ppd file for your printer is located in /etc/cups/ppd/ and can be tweaked if necessary to change the printing area, although I’m not sure that this is the issue you’re reporting.

Thanks for your hint,but it doesn’t work yet.NO device found

The application is Acrobat Reader and the document is pdf type.It is not web page ,but I also try.The problem is still there.
I don’t know how to tweak .ppd file too.

If the YaST printer config worked for you, leave it at that.

Did you check out the printing options available within Acrobat Reader? (I don’t currently have it installed, so I can’t offer specific advice here). Try printing via one of the open source pdf apps (eg okular, kpdf, evince to name a few). This is almost certainly an application-specific issue, rather than a printer driver/configuration issue.

I don’t think it’s an application-specific issue.For three reasons:
<1>the test page is perfect
<2>the first page is also right,just the following pages have the problem
<3>when to print,there are some printers options for work.only when choosing the network shared printer the preview size is 11.78.5(zoom:100%),bigger than the normal size 11.08.5(zoom:94%)
so I think the point is still the driver or something else.Now after several times printing,it can’t work again.My mom,what happening?

Try printing from another application, and other types of document files…same problem? Almost certainly, this will relate to Acrobat Reader. In any case, you might want to start a new thread for this, since it is a different issue from your initial posting, (which is now solved).