To install Nvidia graphics driver, I need to stop the Nouveau driver from loading. It wont work!

I have Opensuse 13.2 x64 installed on my Desktop PC. It has an okay, but older Nvidia graphics card Geforce 7600GT in it. Opensuse installs and runs fine. I’m trying to install the Nvidia graphics driver from Nvidia in Opensuse, but It wont install because it says that the Nouveau KMS Kernal driver can not be running, and the Nvidia install program exits without install. Here is what I’m trying to do to get it to work.

I edit the grub file located here:


I edit the grub file with KWrite. I change the statement below that’s in the grub file by adding in the “nomodeset” parameter at the end of the statement line:

From this:

GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/sda1 splash=silent quite showopts"

To this:

GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/sda1 splash=silent quite showopts nomodeset"

And then I change another statement in the grub file:

From this:


To this:


I save the changes to the grub file and then reboot. After the system reboots, I do this in a terminal:

init 3

To disable KDM, and then enter my user name and password. At that point, I’m in a terminal outside of KDM. Then I become root user and enter this to install the Nvidia graphics driver:

sh ./

And then the Nvidia Linux driver installer starts and does a software integrity check on itself and passes. It then ask me to agree to the license, I press OK and then a message comes up telling me that I need to disable the Nouveau driver from running before the installer can install. At that point, I just reboot back into the GUI.

I have also seen on sites that say after doing the above steps, to open a terminal and do this command so that the changes made to the grub file take affect:

sudo update-grub
root's password:
sudo: update-grub: command not found

But the command fails with command not found. Is there a different way to update the grub file with Opensuse so the changes to the grub file take affect? I’m a Linux newbie. Any help would be greatly appreciated!


Next, you need to:

# grub2-mkconfig -o /boot/grub2/grub.cfg

Then reboot. After that the Nvidia install should go fine.

You will have to reinstall after every kernel update.

In practice, it is less work to just add the Nvidia repo:

Yast → Software Repositories
Click on Add, select “Community Repositories”. Select the Nvidia repo.

Then install the driver from the repo – I’m not sure which driver, but since you have downloaded the Nvidia source, you will quickly recognize which one corresponds. My older box used the drivers (the G02 driver), currently at 304.125. The nice thing about using the repository way, is that it takes care of blocking “nouveau” and it handles kernel updates automatically.

why don’t you just add the nvidia repository and get the prebuild drivers?
no need to mess with *.run files, files that you will have to do run time there is a kernel update.

start yast then goto reposetory managment, click add, select community repo’s check the nvidia reposetory
then goto software management I do believe yast will preselect the proper driver (it has for me) if not search for nvidia I do believe that G02 should support your card (G03 may too) yast will automatically disable the nouveau driver, reboot,
that’s it now when ever there is a driver or a kernel update you’ll get them automatically.

Thanks nrickert, that did the trick! Followed the instructions, let the driver installation utility modify my X file to boot the new driver, and all is good!

with using the .run driver there are ALSO a few other things that you WILL HAVE TO DO !!!
the .run REPLACES the default
and a few others

with DIFFERENT ones from Nvidia


you will want to REINSTALL every "mesa * " and "mesa *-devel " rpm that is installed AFTER you install the .run

there is a reason it is called ** " The Hard Way" **

it you DO NOT reinstall mesa then
programs BUILT with the MESA "GL.h " might NOT work ant more using the NVIDIA

the header and the lib NEED TO MATCH

Me again,

Forgot to mention that I would have done it the Yast–> Software Repository way but my Desktop’s Netgear wg311v3 802.11 b/g wireless wifi card does not supply Linux drivers for it, only Windows drivers. Also, low and behold, at the same time, my Desktop PC’s Marvell Yukon 88E8001 Gigabit Ethernet card (built into the motherboard) is incompatible with my TG862G Xfinity router (running the latest firmware). As soon as I plug in the Ethernet cable to the router and the Desktop PC, the computer locks up. This happens in Opensuse by just locking up, and Windows 7 Ultimate by giving me a BSOD (blue screen of death). Happens every time I plug it it. So I just decided to do it the hard way and download stuff with my laptop and then transfer it to the Desktop PC. This does not happen with my Asus Laptop, or my Dell Laptop if I connect the Ethernet. So, its definitely an incompatibility. Also, in case someone else is reading this trying to figure out how to install the Nvidia driver on their system, I also had to install these 3 rpm packages to build the Nvidia driver first:

Since I’m using Opensuse 13.2 x64, to get the 3 packages I went here: (this folder has both x86 and x64 repositories)

The 3 packages I installed were:

  1. gcc- x86_64.rpm
  2. make-4.0-2.2.3. x86_64.rpm
  3. Kernal-desktop-devel-3.16.6-2.1. x86_64.rpm

Again, thanks everyone for your help! I’m starting to dig this Linux stuff :slight_smile:

you might want to ask in the networking and/or wireless sub-forums for help getting your hardware to work.
if you don’t have a working network on your opensuse and you don’t have the install dvd transferring every needed rpm from a windows box is a nightmare

Cool, thanks for pointing that out. Wow, I can see at the repository site, there’s lots of mesa packages. Well, looks like I have my work cut out!:slight_smile:

Yes, I’ve been looking at this thing called the ndiswrapper that allows you to use your Wifi card’s Windows drivers in Linux. I’m going to look into that more later and see if I can get it to work.