to have the last plasma5 switch to framework5 and qt5 ?

on my leap 42.2 I would like to have the last plasma5
is it enough to swich packages (click on switch system packages in yast>software management) for http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/ ??
or it needs to switch packages also for http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/ ??

and for applications, is ok to switch for http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_Leap_42.2/ ??
and for http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.2/ ??

manythanks, ciao, :slight_smile: pier