/tmp permissions failures in 11.3

At first log-in as user all was fine yesterday. Today I must have rebooted for the first time because it was all different. I tried to log-in to KDE this morning and it failed with some weird error messages that don’t repeat here. It seems it all boils down to the fact that the /tmp folder has the wrong permissions. Whatever I try it always has the permission 755.

It is an encrypted /tmp permission mounted in fstab like this:

/dev/mapper/cr_sda2 /tmp ext4 acl,user_xattr,nofail 0 0

I can login as root in failsafe and look at the tmp folder:

ls -h |grep tmp
drwxr-xr-x  6 root root 4.0K Jul 20 12:26 tmp

So the wrong permissions. How to solve this?

I tried to go into rescue mode and change the permissions of the folder, but nothing helps. In rescue mode it is like it is in my OS 11.2 on another computer:

drwxrwxrwt  6 root root 4.0K Jul 20 12:26 tmp

A temporal work around is to change de permission as root and then I can login, but how to get the permissions right at boot up? What is wrong?

I just checked what happens if I use an unencrypted partition for /tmp and it did not make any difference. Still the same change of permissions.

Putting the rw mounting option does not make any difference either. What am I missing here?

/dev/mapper/cr_sda2 /tmp ext4 acl,user_xattr,nofail,mode=1777 0 0

Add the ‘,mode=1777’ option to the fstab line.

Yes, that fixed it. Thanks a lot!