Title: Autoyast - problems with reusing partitions

Hi all!

I tested a configuration to install openSUSE Leap 42.1 on a Dell Optiples 5040. EFI boot is enabled without secure boot. I want to keep the first two partitions containing efi boot and diagnosis tools. The automatic installation breaks while working the configuration file sl4201x64_dv_dt_s16_test.xml with the following message: “Error while configuring partitions. Try again.” Before I did this attempt I made a default installation of above openSUSE with following partitions

/dev/sda3 / btrfs
/dev/sda4 swap
/dev/sda5 /homte xfs (already removed before autoyast test installation)

Here is the partitioning excerpt of the configuration file sl4201x64_dv_dt_s16_test.xml:

>>
<partitioning config:type=“list”>
<drive>
<device>/dev/sda</device>
<initialize config:type=“boolean”>true</initialize>
<partitions config:type=“list”>
<partition>
<create config:type=“boolean”>false</create>
<format config:type=“boolean”>false</format>
<mount>/boot/efi</mount>
<partition_nr config:type=“integer”>1</partition_nr>
</partition>
<partition>
<create config:type=“boolean”>false</create>
<format config:type=“boolean”>false</format>
<partition_nr config:type=“integer”>2</partition_nr>
</partition>
<partition>
<create config:type=“boolean”>true</create>
<crypt_fs config:type=“boolean”>false</crypt_fs>
<filesystem config:type=“symbol”>btrfs</filesystem>
<format config:type=“boolean”>true</format>
<subvolumes config:type=“list”>
<listentry>.snapshots</listentry>
<listentry>opt</listentry>
<listentry>tmp</listentry>
<listentry>usr/local</listentry>
<listentry>var/crash</listentry>
<listentry>var/log</listentry>
<listentry>var/run</listentry>
<listentry>var/spool</listentry>
<listentry>var/tmp</listentry>
<listentry>var/opt</listentry>
</subvolumes>
<loop_fs config:type=“boolean”>false</loop_fs>
<mount>/</mount>
<partition_id config:type=“integer”>131</partition_id>
<partition_nr config:type=“integer”>3</partition_nr>
<resize config:type=“boolean”>false</resize>
<size>60G</size>
</partition>
<partition>
<create config:type=“boolean”>true</create>
<crypt_fs config:type=“boolean”>false</crypt_fs>
<filesystem config:type=“symbol”>swap</filesystem>
<format config:type=“boolean”>true</format>
<loop_fs config:type=“boolean”>false</loop_fs>
<mount>swap</mount>
<partition_id config:type=“integer”>130</partition_id>
<partition_nr config:type=“integer”>4</partition_nr>
<resize config:type=“boolean”>false</resize>
<size>16G</size>
</partition>
</partitions>
<pesize/>
<type config:type=“symbol”>CT_DISK</type>
<use>linux</use>
</drive>
</partitioning>
<<

Here is the content /var/log/YaST2/disk_sda.info:

>>
<?xml version=“1.0”?>
<disk>
<name>sda</name>
<device>/dev/sda</device>
<size_k>488386584</size_k>
<major>8</major>
<minor>0</minor>
<range>256</range>
<geometry>
<cylinders>60801</cylinders>
<heads>255</heads>
<sectors>63</sectors>
</geometry>
<label>gpt</label>
<max_primary>128</max_primary>
<udev_path>pci-0000:00:17.0-ata-1.0</udev_path>
<udev_id>ata-ST500DM002-1SB10A_WA40DYEA</udev_id>
<udev_id>scsi-0ATA_ST500DM002-1SB10_WA40DYEA</udev_id>
<udev_id>scsi-1ATA_ST500DM002-1SB10A_WA40DYEA</udev_id>
<udev_id>scsi-35000c5009abf24b0</udev_id>
<udev_id>scsi-SATA_ST500DM002-1SB10_WA40DYEA</udev_id>
<udev_id>scsi-SATA_ST500DM002-1SB1_WA40DYEA</udev_id>
<transport>SATA</transport>
<partition>
<name>sda1</name>
<device>/dev/sda1</device>
<size_k>512000</size_k>
<major>8</major>
<minor>1</minor>
<numeric>true</numeric>
<number>1</number>
<fs_type>vfat</fs_type>
<fs_uuid>E05E-2086</fs_uuid>
<fs_label>ESP</fs_label>
<mount_by>uuid</mount_by>
<region>
<start>0</start>
<length>64</length>
</region>
<partition_type>primary</partition_type>
<partition_id>259</partition_id>
<boot_flag>true</boot_flag>
</partition>
<partition>
<name>sda2</name>
<device>/dev/sda2</device>
<size_k>3145728</size_k>
<major>8</major>
<minor>2</minor>
<numeric>true</numeric>
<number>2</number>
<fs_type>vfat</fs_type>
<fs_uuid>AA7B-42AC</fs_uuid>
<fs_label>OS</fs_label>
<mount_by>uuid</mount_by>
<region>
<start>63</start>
<length>393</length>
</region>
<partition_type>primary</partition_type>
<partition_id>12</partition_id>
</partition>
<partition>
<name>sda3</name>
<device>/dev/sda3</device>
<size_k>41950208</size_k>
<major>8</major>
<minor>3</minor>
<numeric>true</numeric>
<number>3</number>
<fs_type>btrfs</fs_type>
<fs_uuid>985e8945-19b2-4845-abf3-820bf0846d8f</fs_uuid>
<mount_by>uuid</mount_by>
<region>
<start>455</start>
<length>5224</length>
</region>
<partition_type>primary</partition_type>
<partition_id>131</partition_id>
</partition>
<partition>
<name>sda4</name>
<device>/dev/sda4</device>
<size_k>33262592</size_k>
<major>8</major>
<minor>4</minor>
<numeric>true</numeric>
<number>4</number>
<fs_type>swap</fs_type>
<fs_uuid>222965c0-2363-4816-909a-9e9ddfc44826</fs_uuid>
<mount_by>uuid</mount_by>
<region>
<start>56660</start>
<length>4141</length>
</region>
<partition_type>primary</partition_type>
<partition_id>130</partition_id>
</partition>
</disk>
<<

I have made a log of “fdisk -l”, too:

>>
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: D3870915-D7B0-4A9C-BC95-BD5610D6A048

Device Start End Sectors Size Type
/dev/sda1 2048 1026047 1024000 500M EFI System
/dev/sda2 1026048 7317503 6291456 3G Microsoft basic data
/dev/sda3 7317504 91217919 83900416 40G Microsoft basic data
/dev/sda4 910245888 976771071 66525184 31.7G Linux swap

Disk /dev/loop0: 43.8 MiB, 45875200 bytes, 89600 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 8 MiB, 8388608 bytes, 16384 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 54.7 MiB, 57344000 bytes, 112000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 60.9 MiB, 63832064 bytes, 124672 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop4: 4.1 MiB, 4325376 bytes, 8448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop5: 5 MiB, 5242880 bytes, 10240 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop6: 128 KiB, 131072 bytes, 256 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sdb: 7.8 GiB, 8321499136 bytes, 16252928 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xc3072e18
<<

What went wrong?

Thank you very much.

Best regards

SuseUser02

I think it’s caused by the “mount_by” which is set to uuid, which means it will differ on each system.

Hello Knurpht!

I am sorry for the late answer. Thank you for your hint.

I experimentes mount_by but without success. So I had a sharp look at the Autoyast documentation and found the reason: If you want to keep partitions you have to disable the initializing of the drive. The documentation states: ‘If set to “true”, the partition table gets wiped out before AutoYaST starts the partition calculation.’ So I corrected this tag as follows:

<initialize config:type=“boolean”>false</initialize>

The problem was solved this way.

Best regards

SuseUser02