Tired with ATI drivers installation =/

Hi there.
I have tooke about a week trying to install my HD2400 RADEON drivers (ASUS F3s) but can’t get it work.
I tried with the one from ATI’s website but when I restart my laptop it get frozen with a black screen. I can’t even go to console mode (Ctrl + Alt + F1). I have to change Sax2 to Vesa for windows mode again.
I’m not sure what packages do I need to install and what others no.
What is the XGL, the Xorg and the X server exactly?.
By the way when I tried to config the ATI drivers with aticonfig --initial a message says: “No X server is running”.

It was running only one time but my failure was to update it ._.

Thanks guys!.

That is a bit strange. Please paste content of your xorg.conf file here (xorg.conf is located in /etc/X11 folder) to see if it is setup correctly.

I had the same problem with my Toshiba lappy (ATI Xpress X1200). I thought I was going crazy! I tried ALL the usual tricks and nothing worked…

Everything was working great for months (3D, Compiz, etc) until I updated the ATI drivers. I messed with it for 2 weeks, trying the fix the problem. Finally, I wiped the partitions and did a fresh install of openSUSE 11.1.

To make sure the problem was the new ATI drivers, the first thing I did, when I got openSUSE running again, was to upgrade the ATI drivers, and I was met with a ‘black screen’ again on the next reboot.

I’m convinced the problem is the new ATI drivers!

I was so pissed that I installed Linux Mint 6 x64, and it’s been working great, so I haven’t reinstalled openSUSE on my lappy. If/when I do reinstall openSUSE, I’ll use an older version of the ATI drivers! I recommend you do the same - and once you get it working again, don’t upgrade your ATI drivers again…

I always download and install ATI drivers from ATI site, and it always worked for me. This is how I do it every time:

  1. download drivers from ati site
  2. run the installer and install
  3. type aticonfig --initial
  4. modify xorg.conf, remove some duplicated sections and add some fglrx options, aiglx and composite section
  5. run aticonfig --input=/etc/X11/xorg.conf --tls=1

Pnguin please help a begginer understand what you are saying.I really want to use my 3d and compiz

i head excellent luck with the one-click installs from opensuse.org–>get it–>typing in radeon or ati … theo

I get the same problem.

Using a ‘radeon HD 4870 x2’.
I tried:

The Easy Way

The easy way of installing the proprietary driver has the benefits of being easy and does not require that one recompile the kernel module when updating the kernel. Please keep in mind that many older ATI cards are supported very well by the standard free driver. If you have such a card, consider sticking with that driver.

Before using the drivers below, try running your 3D application using the default open source drivers: radeon (for older cards) and radeonhd (for newer cards)
[edit]
1-click install for openSUSE 11.1, 11.0 and 10.3

You can use 1-click-install that will install the latest fgrlx version:

* Do an online update. If you don't you may download the version for the debug kernel. The first time you do this, the online updater will update itself. You should do it a second time immediately to get the other updates that it skips while updating itself.
* 1-click.png Installs newest available drivers. 

* Open a terminal and type 

su -c ‘SaX2 -r -m 0=fglrx’

This will configure X to use the ATI driver.

* Restart X window manager by pressing CTRL+ALT+BACKSPACE (Twice for 11.0 and later). It will take 3-20 seconds. Alternative, you can restart openSUSE.
* Skip all steps below and start using openSUSE! 

See: ATI Proprietary Linux Driver Releases for compatibility lists.

ATI Radeon Xpress - openSUSE for problems with Radeon Xpress Series

Didn’t work.

Then I tried :

La méthode facile

La procédure d’installation des derniers drivers propriétaires est devenue très simple, car la distribution openSUSE bénéficie d’un dépôt directement fourni par AMD. Cette technique est donc par conséquent la plus simple et celle que nous vous recommandons.

Pour commencer il vous faut ajouter le dépôt correspondant à Yast :
Image:susemini.png
Version:
11.1
http://www2.ati.com/suse/11.1
Image:susemini.png
Version:
11.0
http://www2.ati.com/suse/11.0
Image:susemini.png
Version:
10.3
http://www2.ati.com/suse/10.3
A noter que les liens ci-dessus ne sont pas consultables avec un navigateur internet.

Puis installez les paquets x11-video-fglrxG01 ati-fglrxG01-kmp-default.
Utilisez cette commande afin de générer le nouveau xorg.conf (une sauvegarde est automatiquement faite)
sudo aticonfig --initial

Et finalement redémarrer votre ordinateur ou reconnectez-vous à votre session.

Well… This way isn’t in the english wiki.

It didn’t work either anyway…

So I tried this:

  1. download drivers from ati site
  2. run the installer and install
  3. type aticonfig --initial
  4. modify xorg.conf, remove some duplicated sections and add some fglrx options, aiglx and composite section
  5. run aticonfig --input=/etc/X11/xorg.conf --tls=1

Didn’t work.

Oh well, I tried something like 5 other ways that I found on google, I gess some were outdated…

Then I tried a mix (well, when all hope is lost…) :
I did the ‘french way’ then reboot.
I went to the console mode (safemode and ctrl+alt+F1) to look at the xorg.conf
Then I came back to the terminal and tried :
aticonfig --initial -f then just aticonfig --initial
I went back to the xorg.conf and it was completely different from before…

I gave up , downloaded Linux Mint, just burned the iso, and reboot, well it shows tons of errors (I quit after ten minutes of errors).
I went back on opensuse to download debian, it does the same thing as the ati drivers on openSUSE but without having them setup.

Well… Now I need some advice, what can I do to have accelerated 3D on linux (exepted go buy another card -not enough money anyway-)?