Tip: KDE Rebind "Windows Menu" shortcut

Using: openSUSE 12.2, KDE.
Having used Ubuntu/gnome 2 for several years, I had become used to the speed of ALT+Space to bring up my window menu for rapid maximize/normalize/minimize functions. Eventually I found this bound to ALT+F3, a horribly awkward binding in KDE (as found in the Wikipedia shorcuts table). I couldn’t find any easy documentation on changing this, so I thought I would share here.

Applications -> Configure Desktop -> Shortcuts and Gestures -> Global Keyboard Shortcuts

here, as a newbie, I hadn’t realized you could drop-down on “KDE Components” (with so many options, I start to miss things). I honestly thought Amarok was the only program with global shortcuts! FACE PALM
Anyway, go to KWin and search “menu”. The only option that appears for me is just what you want: “Windows Operation Menu.” I rebound mine to Alt+Space.
Once again, altogether thats:

Applications -> Configure Desktop -> Shortcuts and Gestures -> Global Keyboard Shortcuts | KDE Component: KWin : Search: “menu”

Link with picture: https://plus.google.com/u/0/108510065567203615422/posts/373xYfv3BJ9
If anyone has improvements on my instructions, please share. Hope this helps save someone time.

Consider posting your tips in the following forum

If if you are more of of gnome guy(used Ubuntu/gnome 2 for several years) you could try openSUSE:GNOME Cinnamon - openSUSE

Ofcourse you need to install shell first and then install Cinnamon on top of that


I’ve posted there, too.
I’m going to stick with KDE; overall, I think I like it. I just have some quirks to work out.
Also, I am really enjoying Plasma.