Time set incorrectly on booting 11.1

I have a problem that I just starting having after upgrading
my laptop from OpenSuSE 11.0 to 11.1.

When I boot up, the time gets incorrectly set to 5 hrs ahead.
The OS is acting as though the BIOS clock is set in UTC rather
than in localtime. (It’s not, but local TZ is US/Eastern which
is 5 hr difference from GMT.)

I’ve confirmed my BIOS clock is set to localtime.

I’ve confirmed (via Yast2–>System–>Date and Time) that the
“Hardware Clock Set to UTC” checkbox is not checked
and that the timezone selected is “Eastern (New York)”.

Still, the time displayed by ‘date’ and the ‘Clock’ applet
is 5 hrs ahead of where it should be. (Note that the ‘date’
command does display the correct timezone and that I have
no timezone related environment variables set in my environment.)

I even configured NTP to use my local IPCop as primary source
and 0.pool.ntp.org, 1.pool.ntp.org, and 2.pool.ntp.org as
additional servers.

Even with NTP, it still doesn’t work. (Actually, that was a
long shot and I didn’t figure that would fix it. And upon
rebooting this morning, the NTP logs tell me that the various
{0,1,2}.pool.ntp.org host names are not resolving, even
though they did last night when I tested this. But I think
that’s because I’m running of wireless and the wireless network
isn’t up when it boots because I’ve not yet entered the
passphrase for the NetworkManager GPG keyring…automating
that is on my TODO list.)

So does anyone have an suggestions on how to fix this or what
the cause is? If OpenSuSE is interpreting the hardware clock
to be in UTC rather than localtime, it’s going to add 5 hrs
to display time in US/Eastern timezone. I think that’s what
it is doing even though the checkbox on the Yast2 module
is unchecked for that.

Thanks in advance,

As I known, The same problem exists in newlly installed opensuse 11.0
And there is an update for opensuse 11.0 about timezone.
After update, the problem would be solved.

but how can opensuse 11.1 comes with the same problem ?:frowning:
and what is more, there is no update for it so far…

And each time I booted, I gotta adjust the time. Is there any solution ??? We should not past the time as fast as the bug does. it should be a but, isn’t it ?:open_mouth:

same problem with my 11.1 installation.tried setting it to ntp.my 11.0 installation used to correct the time when i connect to internet (i use a DSL connection and so it is not always up )
i hopped it would be the same with 11.1 but it is not so.
i got sick and tired of correcting the time every time i start my system.and so i just removed the clock applet from the panel

Removing any clock from sight does not set it right…There’s a couple of possible causes:
During install UTC (Universal Central Time) was checked. Yet in almost any clock for the desktop you should be able to set it to the local time, and it should be right.
Somehow the BIOS clock went wrong. Rebooting, entering BIOS setup and adjusting time there should do the thing then.
You configured NTP on a laptop. No connection means no NTP server available, what happens next?

removing clock will not set the thing right…but at least i will not be looking at the wrong time and adjusting it.
i did not check the UTC ( checked and rechecked it )
bios clock is fine.only every time i boot into suse the time jumps ahead taking the system time as UTC ( again i did not check the UTC )
well i dont know how it worked i had similar settings in 11.0.same as 11.1 the time used to go system time + time diff.but when i connect my DSL connection the time used to adjust to the right time. i was hopping something similar will turn up but 11.1 is giving me more problems than 11.0

I solved that problem with the help of mailinglist.
I have a separate partition for /usr
and the /etc/localtime is a soft link to the /usr/share/zoneinfo/****, just copy that file to the /etc, and rename it to localtime. it works.:slight_smile:
if you r another problem. I think this wont help.