Tilix symbol lookup error


tilix cant start after 20180820

Besides the usual log, only this stands out

tilix: symbol lookup error: tilix: undefined symbol: _D4glib3StrQe9toStringzFAyaZPa

Another reference for the same error message at:

I am seeing exactly the same error.


For both of you: was your system updated by ‘zypper dup’ ? If not, do so first and report of the error persists.

Hi, Knurpht. I can confirm that this still persists even after zypper dup. My current snapshot number is 20180820.

Updating tilix from TW 20180827 fixed the problem for me. I only did a zypper up tilix, because being on a mobile connection and the zypper dup begin a rather large update.


Since the only proper way to update Tumbleweed is zypper up if you use TW you must have a proper network setup . A phone is just not going to cut the massive updates for TW unless you are very very rich. I suggest you drop back to Leap:O

Sorry for not being clear enough. I did type the message in a bit of a hurry. Tonight I did a proper zypper dup and all is fine. While commuting I noticed a new TW snapshot and instead of doing a full zypper dup I opted to just update tilix and feed my curiosity if that would solve the issue. It did :slight_smile: and I could do that while being on a mobile connection. I could have done a full zypper dup while being on a train, but the packages surly would not have been downloaded before I reached my destination. Hence just a quick update of only tilix.

Oh, as for a fast network (I want to brag of course. I hope I am excused) at work I get approximately 960 MB/s down (yes, that’s bytes) on a cable. At home, I am not that well connected :frowning: still at 250 Mbit/s…

Yes. zypper dup from 20180820 to 20180827 also solves my problem.

Thanks everyone!