Hello Freaks !

Does anybody here has made experiences with tiling-WMs ?

  • Are there any in our repos,and there ?
  • Do they run under the normal DE,or only solo ?
  • Can I use all programs with them ?

Actually,I´m using openSuse 11.3 with KDE 4.4.

Any information will be appreciated !

Greetings !


Hello lostinspace,

I have also seen another thread you started. I do not know what browser you use, but most other people’s browsers do show the default text of these forums adequate. Thus there is no need from our side that you increase the font of your post. It may even lead to people becoming irritated and thus skipping your thread, which might not be in your interest.

Thus when you have no problem yourself in reading the deafult font, please use it. When you have a problem, please state this clearly so that others may post back in the same font for your benifit.

Hello all !

Sorry for the blowed-up font! I had a new installation,and have to resize the
system/browser-fonts.But late at night,I didn’t get the consequence of enlarging
the font for the readability !

Greetings !


On 01/23/2011 03:36 PM, lostinspace wrote:
> ::Hello Freaks !
> Does anybody here has made experiences with tiling-WMs ?
> - Are there any in our repos,and there ?
> - Do they run under the normal DE,or only solo ?
> - Can I use all programs with them ?
> Actually,I´m using openSuse 11.3 with KDE 4.4.

The repo of interest is:

The repo contains ‘awesome’-3.4.9, ‘echinus’-0.4.3, ‘euclid-wm’-0.2.0,
‘scrotwm’-0.92.8 (no scrotum jokes, please), and ‘wmii’-3.6.3.
These window managers are meant to replace KDE or GNOME. The idea is to
do away with eye-candies and ‘useless’ bits that come with DE.

Unlike ‘openbox’ and the like, these do not run under DE, as far as I
know. They are stand-alones.

So long as dependencies are met, any program can be used. You may have
to know the exact name of the executable file, though.

For some reason, I’ve had troubles using all these four WMs with
openSUSE 11.3 (with supplied RPM packages.).

  1. euclid-wm: It turns out that the WM was not picking up keyboard
    events from my keyboard (Happy Hacking Keyboard Lite 2). The trick is to
    have the “NumLock” key turned off (from ‘aur.archlinux.org’). Since the
    HHKB does not have “NumLock”, I have confirmed this behaviour with a
    cheap MicroSoft ‘Chiclet’ keyboard. This WM compiles fast, by the way.
    You should have no problem here. Get it from the repo and turn off

I don’t use it: it feels too much like 'wmii’and I can’t use my HHKB.

  1. echinus: I had to create $HOME/.echinus and copy echinusrc here,
    before I could use it. I gave up on this. I could not find a simple way
    to call up a program except at the command-line in a terminal.

  2. scrotwm: It comes with numerous files (for a window manager)
    scattered all over. Tried to compile, too; never got it going.

  3. wmii: This used to work right from openSUSE Build Service. But
    something changed and would not work. Compiled from a tarball
    (‘wmii+ixp-3.92’ from sucless.org). It works; had to create
    ‘wmii-desktop’ in /usr/share/xsessions/, in order to have it appear on
    the KDM. This WM has an annoying habit, for me, of stretching out almost
    all pop-up window to the max, like the Firefox Download pop-up. I use
    this WM.

  4. awesome: This is very nice; I use this. Except that you will NOT be
    able to use it as supplied in the repo. Most likely you cannot even
    install it from YaST2, because of a dependency issue. Compiled from a
    tarball (v3.4.8); unlike ‘wmii’ or ‘euclid-wm’, this WM has a big list
    of needed packages. Had an issue with ‘lua-doc’/luadoc’ issue, but this
    does not seem to affect my simple-minded use of the WM.

The problem is that a needed feature in a package has been removed
‘upstream’ (as noted by the packager or maintainer V. Untz). The package
is ‘cairo’/‘cairo-devel’ (renamed, too). The newer version does not have
‘xcb’. I had to downgrade the package (to v1.8.10) to compile and have
to retain this version to keep using my own compiled ‘awesome’, as well.

Hello Taki !

Thanks for your summary,experiences and the link!On the Awesome-Wiki,I found an
overview with several WMs,including most(?) of the Tiling-WMs.
I’m a little conflicting between eyecandy up to blindness,and on the other hand,
a very frugal,just useful workspace.
Most interested I’m in a TWM,which integrates into KDE,or can be started on
user-change,where all the other DEs are listed.
A lot of stuff to work through,nothing else to be done…

Greetings !


How about using KWin’s tiling functionality?

Can be turned on under ‘Personal Settings > … > Window Behaviour (‘kcmshell4 kwinoptions’) > Advanced’.


KWin - the KDE window manager supports rudimentary tiling since KDE SC 4.4 (side-by-side) and full tiling since KDE SC 4.5


Hello Lord_Emsworth !

Yes,on my search,I stumbled upon the info,that there is a tiling-function,but only
since KDE 4.5 !
Just tried (again) to find such setting under KDE4.4,there isn’t any!Do you mean
the setting-menu with economic,maximize,staggered,random,centered and upper left
corner window-placement(under KDE4.5,additional there is the option “in rows”)?
The last one,I tried with KDE4.5,but it seems to be very rudimentary,too.
Or is there any other setting?

As a shame for me,and probably a help/warning for others,I’ll post here my try to
change to KDE4.5 :
-never updated the recent 11.3 since installation on 64-bit!
-trying to get KDE4.5 by adding both KDE-Repos (release 45 and extra release 45),
and changing the vendor in Yast2
-seems to work at the first glance,there was the option “in rows” in the setting
for window-placement
-checked it out,but it only placed the new windows in rows,after changing the size
of the window and resize it,it was placed in the upper left corner,not at its old
-not really satisfying,and,not enough,I played around with the settings for the
-my favourite one,wobbling windows,lastly led(forced) me to new-install the whole
After setting up the wobbling too strong,the window gets fully torn to pieces,and
ran diagonally over the screen.No chance to stop/close it.Reboot and even change
back the vendor,doesn’t helps!So…

Do I hear someone laughing here ?

Greetings !


Not laughing, a tiny smile here. Since this can easily be reset by removing the plasma config files:

Hit Ctrl-Alt-F1
login with username and password and do:

rm ~/.kde4/share/config/plasma* && exit

Hit Ctrl-Alt-F7
login and your desktop appearance will be back to the beautiful openSUSE 11.3 default desktop :smiley:

Hi Knurpht !

You are right,but I feel better now,having a freshly updated(zypper refresh + dup)
system now running !

Greetings !


You re-installed the whole system because of a bad setting for one desktop effect?? You should just have deleted/renamed the desktop effects settings file, which is somewhere inside ~/.kde4 . Logging in to an IceWM session (or so) should be helpful for doing that. :wink:

And wrt the tiling of KWin. I don’t use it myself, so I have no idea how good it is. But anyway, since it seems to be a nascent feature, it is probably a good idea to keep an eye on it, if you like window tiling.

Hi Lord_Emsworth !

Yesno!Not allone caused by the desktop-problem,but think of the state of the system,
not beeing updated since its installation!And lastly,I feared for the stability and
consistancy of the system,updating it after such a long time!

Greetings !


Hello,all around !

Now I do have some experiences with a Tiling-WM,too.Great art of working with it!
My decision was Xmonad,had to install GHC (Glasgow Haskell Compiler) and Cabal (Common
Architecture for Building Applications and Libraries) for it,seems to work.
Perhaps,I will post a review of my way to and with Xmonad…

Greetings !


It’s been a while since I used Xmonad (used it when I was trying out FreeBSD) but as far as I can remember I had a great experience with it.

KDE 4.5 also have a spiral tiling option. The first window take all the desktop, and each subsequent window will shrunk the last one by half and take the free space, in an spiral order.
It is interesting, if a bit unsettling when you’re not used to it.

Hi ah7013 !

Do you remember something about Xmonad,yet,to give some hints?
I (think I) know all relevant sites on this topic,but there are some questions left :

  1. For the buildings and installations with Cabal,the default setting to use “local” can be
    changed in a config to “global”.
    Can Cabal itself be installed “global”,too?
    Or is the “local”-installation for Cabal a must,to have connection to the different configs
    etc. stored there ?
  2. There are suggestions,to use only one workspace in KDE,if you use Xmonad with some of the
    extensions.Do you know something about this topic ?
  3. Do you have some configs left,you would like to share ?

Greetings !


Hello brunomcl !

On my short test with KDE 4.5,the tiling-function there seemed not to be too matured.
If you change the size of a window,and then resize again,the window is displayed f.e.
at the home-position,not at its recent one.
But the working behaviour with real tiling gives you such an experienced workflow,like
said in Xmonad’s title :"…it rocks!"

Greetings !


Hi lostinspace,
When I used Xmonad I used it on its own (without KDE, GNOME, etc). In FreeBSD I added Xmonad to my .xinitrc with XDM display manager to log in.
Being me I didn’t really bother to customize Xmonad (should have though I’m just lazy) so this was the config I used which is actually default (lol):

main = do
    xmonad $ defaultConfig

However there are quite a few interesting configs I found at this website:
Xmonad/Config archive - HaskellWiki

I think this depend on the settings for “floating windows”, whatever that means… KDE4 still lack documentation/help, although it is improving.

With the “not-floating” windows, moving one over another switch their positions and sizes. It is probably productive if/when you get used to it.

Hello ah7031 !

  1. Question was solved,by looking around in my directories:Cabal already is beeing installed
    globally! It only puts its working-directory into the local directory,which can be changed.
    And may be,it is placed right,there,because of the permissions.
  2. Created a special user for the Xmonad,where I only use one workspace with KDE.

Xmonad will also not be added automatically to the login-menu under KDM,so I had to create
an “xmonad.desktop”-file for the xsessions.
After installing some of the extensions,now I’m trying to use them.

Greetings !


Hi brunomcl !

First,I have to upgrade my KDE4.4,and then I will examine it a little further.

Greetings !