Tijdens update wordt niet alles geinstalleerd.

Hi,

tijdens het updaten van mijn opensuse 12.1 KDE, viel mij op dat niet alle pakketten geupdate worden. Althans ze worden niet geinstalleerd. Het betreft een beste lijst:

“The following package updates will NOT be installed:
amarok autofs bea-stax-api bluedevil bluedevil-lang boost-license1_46_1 choqok curl digikam digikam-doc digikam-lang
DirectFB DirectFB-Mesa exiftool gettext-runtime gimp gimp-help gimp-help-browser gimp-plugins-python gstreamer-0_10
gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good hplip-hpijs jline jpackage-utils k3b
kio_audiocd kipi-plugins kipi-plugins-acquireimage kipi-plugins-geolocation kipi-plugins-lang kmix konversation
konversation-lang kscd ktorrent libbluedevil1 libboost_filesystem1_46_1 libboost_program_options1_46_1 libboost_regex1_46_1
libboost_signals1_46_1 libboost_system1_46_1 libboost_thread1_46_1 libcares2 libcurl4 libdirectfb-1_4-5 libedit0
libexiv2-11 libftgl2 libgimp-2_0-0 libgimpui-2_0-0 libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libidn
libkcddb4 libkcompactdisc4 libkface1 libkgeomap1 liblastfm0 liblzma5 libmygpo-qt1 libmysqlclient18 libmysqld18
libnsssharedhelper0 libproxy1 libpyglib-gi-2_0-python0 libqjson0 libquicktime0 libreoffice libreoffice-base
libreoffice-base-drivers-mysql libreoffice-base-extensions libreoffice-calc libreoffice-calc-extensions libreoffice-draw
libreoffice-draw-extensions libreoffice-filters-optional libreoffice-help-en-US libreoffice-hyphen
libreoffice-icon-theme-crystal libreoffice-icon-theme-galaxy libreoffice-icon-theme-hicontrast
libreoffice-icon-theme-oxygen libreoffice-impress libreoffice-impress-extensions libreoffice-kde4 libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-templates-en libreoffice-templates-labels-a4
libreoffice-templates-labels-letter libreoffice-templates-presentation-layouts libreoffice-thesaurus-en-US
libreoffice-writer libreoffice-writer-extensions librest0 libSDL-1_2-0 libsmi libsmi2 libsqlite3-0 libssh2-1 libstrigi0
libtheora0 libvisual libwavpack1 libxmmsclient6 libxmmsclient-glib1 linphone mjpegtools MozillaFirefox
MozillaFirefox-branding-openSUSE mozilla-kde4-integration myspell-american mysql-community-server
mysql-community-server-client NetworkManager-kde4-libs NetworkManager-openvpn-kde4 NetworkManager-pptp-kde4
NetworkManager-vpnc-kde4 oxygen-gtk perl-Config-Crontab perl-Crypt-SmbHash perl-Digest-HMAC perl-Digest-MD4
perl-Digest-SHA1 perl-gettext perl-HTML-Parser perl-HTML-Tagset perl-NetxAP perl-Parse-RecDescent perl-TermReadLine-Gnu
perl-X500-DN perl-XML-LibXML perl-XML-NamespaceSupport perl-XML-Parser perl-XML-SAX perl-XML-SAX-Base perl-XML-Simple
perl-XML-XPath plasmoid-networkmanagement python-cairo python-distribute python-gobject python-gobject2
python-gobject-cairo python-gtk python-notify python-numpy python-pycurl python-pyudev python-simplejson python-sip rhino
shared-desktop-ontologies skanlite sox strigi transmission transmission-common xalan-j2 xerces-j2 xerces-j2-xml-apis
xmlbeans xmms2 xmms2-plugin-base xmms2-plugin-flac xmms2-plugin-flv xmms2-plugin-m3u xmms2-plugin-mp4 xz”

Wat kan hier de achterliggende gedachte achter zijn?

Dat komt omdat je repos hebt toegevoegd, en daarbij hebt aangegeven, dat zypper de pakketten uit die repos moet halen. Beste voorbeeld is Packman. Je hebt aangegeven dat alle multimedia pakketten uit die repo moeten komen. Als er dan updates voor die pakketten in andere repos verschijnen, worden die, conform jouw instructies, niet geïnstalleerd. Hetzelfde voor de KDE pakketten die in de Update repo verschijnen. Ik denk dat je een extra KDE repo hebt. Hoe meer repos je toevoegt en bestempelt als de plek waar pakketten vandaan moeten komen, hoe meer pakketten je hier zult zien.
Kortom, de signalering is juist, de conclusie die je er aan verbindt niet.

Ok,das duidelijk. Bedankt :slight_smile: