Thunderbird Search Stopped Working


Just had an update for Thunderbird (and Firefox) and Thunderbird search is not working - anyone else having the same problem ?.

Thanks and regards,


Nope, but if you mean “Global Search and Indexer” thing I would do this as first step.

Might have gone bad for some reason and it wont hurt.

If you mean normal simple search it is very weird.

Does not seem 31.6.0 introduced anything new which could mess up.

HI JS9600,

Thanks - Yes - i mean the normal search at the top rather than the quick filter. Agreed the search is weird.

I am rebuilding the indexing - thanks for the link.

Hopefully this will resolve.



If not helping then you should probably try disabling all extensions you might have.

Still not working then try start “thunderbird” from terminal, see if it says anything but 1 “GLib-CRITICAL” which it does in my KDE.

Seems like it must be internal Thunderbird issue though.

Can also try to open “Error console” in Thunderbird, is under “Tools” menu. If lucky that will show an error when you click search and point to source. This can be used to narrow down which extension is a problem. You could have 30 installed.

If you can sort of rule out openSUSE and no one has a clue I would suggest to post here and let them have a go. If you click around a bit you can see they are used to almost any imaginable issue.

Have the feeling you will be told to also delete localstore.rdf but am speculating. Think it holds data on GUI, placement of buttons etc. I can remember having corruption in that using Firefox. Years ago but something never change. Best to ask on that forum first but is harmless to tinker with except you will start up with default settings and lose customizations.

Forgot Thunderbird is practically Firefox.

So, to rule out openSUSE and probably give hope you can make a new profile.

Start it up like “thunderbird -profilemanager”, you get a little window where you create new profile.

Be sure to remove the tick in “Use the selected profile without asking at startup”.

Start it up, choose new profile.

If all buttons are functional openSUSE has nothing to do with issue. Does that not hold water?

Can actually continue using that profile, swap old with new. Done! Might have to move some folders too.

But then you will not know why there was a problem. Is like cheating :slight_smile:

Hi JS9600,

The index completed and still the same issue. I am searching on “lg” where i know i received an e-mail from them and no results - yet other words are OK- so it must be this specific phrase not indexed, from the root Inbox folder.

Since it is working for other words - i will have to track the e-mail manually - long job.

Thanks for your help,