Thunderbird puzzle

On a workstation running Leap 15.3 with Thunderbird 78.13.0 (64bit) I can see all the messages in my inbox.
On my laptop running Tumbleweed with Thunderbird v91.3.0 (64 bit) there is one message at least not visible in my inbox.
I only know this because the subject message had been present and I had tagged it as the subject matter required me to take action later.
When I went to my laptop later the message was not there.
I checked the IMAP server using webmail and the message is still there where it should be, so what is going on with T’bird and TW I ask.
Anybody else experienced this? It could cause a major incident and it was only because I am running different computers that I found out about it.

I cannot understand exactly what is going on in your installation. Perhaps there are issues in your account preferences regarding what is done with the emails after they are received or sent? I would have a look at such settings.

I have done some digging and whilst I cannot link the above problem I reported to any particular fault I do have an error built into my Thunderbird installation.

In short, in order to set up T’bird on this laptop and to save all the hastle of building from the bottom up I used a saved copy of my old profile to the new installation and made it my default. I did this a long time ago and cannot remember the details but the account settings on the present configuration are all correct for connection to the Imap server of my ISP and everything has been working, I believed OK until I wished to install QuickFolders.

There is no fault with QuickFolders but I now find that information hidden in plain sight within the working default profile uses an obsolete Imap mail server address in the URI of each folder. This dated from before my ISP upgraded their servers and changed the Imap server address. This information only surfaced when QuickFolders tried to create tabs which I had also copied from another machine.

As far as I can see the error might be within the default profile subdirectory /ImapMail where I have 4 mail addresses and 4 .nsf files. I have no idea what these are or what they do but some have not been used since 2020 and others used today. The bottom line however is that whilst the settings for my email account are correct and use the present and published ISP’s Imap mail server settings, my Inbox URI actually shows the old Imap server address. How on earth this still worked I have no idea and if anybody can shine any light on this I would appreciate it. More important, how do I correct the problem?