thunderbird opens link with wine-firefox instead o linux-firefox

on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, OS=opensuse 13.1 KDE= 4.13.1

as I need to see an ip camera I installed firefox on wine, but now thunderbird opens the links in emails with firefox installed in wine, before TB opened them with firefox in linux.
how can I have links opened with firefox in linux as in the past??

manythanx, :slight_smile: ciao :slight_smile: pier…

On 2014-05-19 12:06, pier andreit wrote:

> how can I have links opened with firefox in linux as in the past??

I wonder if FF has a “check if FF is default browser” button somewhere.

I started Chrome yesterday and it asked me if I wanted it to be set as
default browser (I said no), so perhaps FF has it somewhere, too…

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Edit => Preferences => Advanced

It is on the bottom of the General tab.

… but, whether or not it will fix this particular problem, dunno.

  1. Check default browser in KDE settings (System Settings > Default Applications > Web Browser)

  2. What happens when you run firefox from the terminal? It should run the native version of firefox instead of the wine version. If not then maybe something is wrong with your PATH variable.

I have tried changing the default browser to Qupzilla and Thunderbird will open links in it so see if that helps you.

I did both, unchech the “check if FF is default browser” in the wine version, checked in the linux version, and re chosen firefox in System Settings > Default Applications > Web Browser and now it works, manythanks…:slight_smile:

No problem, I have had similar issues before :slight_smile: