Thunderbird Lightning 11.4

I have been running Thunderbird with Lightning on my laptop, with recent upgrade to 11.4.
KDE 4.6.3, Tbird is 3.1.10, Lightning 1.0b2

The calendar in Tbird(provided by the lightning add-on) is misbehaving. The calendar view is stuck on Day (even with month selected), New calendar add function does not work and events won’t add.

Anyone with similar issues, or better yet, suggestions?

I have tried Tbird 3.1.7, 3.8.8 and 3.1.10, with similar results.

I’m running 3.1.10 with Lightning 1.0b2 on openSUSE 11.3 with no problems. No idea what to suggest.

Thanks for comment.
This laptop was 11.3 and no problems, but a Tbird release earlier than 3.1.7, I believe, when I upgraded.
What is interesting is that my desktop, also 11.4, last I saw it, was running fine as well.
Unfortunately, I am on the road for extended time and can’t do a detail compare.

Same here ex. on 11.4, very stable

Thanks for the additional performance confirmation.

I have made some progress, now have to figure out how to get back to where I want to be.

What follows is for anyone else in my situation:

Proof it does work:

  1. I created a test login for a new user.
  2. Started Thunderbird 3.1.10, connected to my mail server, which sets up a new, default profile in /home/username/.thunderbird directory. Received email that is currently on the server. So, basic TBird working.
  3. Using Tools-add-ons, installed the Lighntning 1.0b2 for x86_64 .xpi I had downloaded from Mozilla ftp. Can’t uses the Add-ons search in Tbird for this step, as it will bring in the 32 bit version of Lightning. I suggest a google search for “thunderbird lightning 1.0b2 x86_64” so as to get familiar with where future x86_64 xpis may need to be found.
  4. After step 3, a new “Home” calendar was active and seemed normal.
  5. As a follow-on to item 3 above, there appears to be a lot going on in Mozilla thunderbird space. The TBird 3.2 release has been put on the back burner, appears TB3.3 will be next up and TB 3.4 is also being worked. Navigate the ftp sites carefully to get the correct Add-on.

What I am trying to recreate, but have failed so far:

  1. Starting a year ago, while running Win7 and 11.3 on this laptop(dual boot), I found a Mozillazine article on how to manage Thunderbird running on either platform.
  2. I suggest again a search on the topic if you are interested; the article I found was rather old and may have been updated.
  3. Essential are: You need a Tbird profile for Windows and a Tbird profile for Linux, since add-ons and other settings are OS unique. The actual mail folder can be shared, but for Win7 to be able to access it, it must reside on an NTFS partition.
  4. In my Win7/11.3 solution, I have a Thunderbird folder on the Windows NTFS partition
    that holds three sub folders, one for Win7 profile, one for 11.3 profile and one for the MAIL directory.
  5. So my task now is to find out why the Lightning add-on won’t install correctly. My suspicion is it has to do with file permissions on the NTFS partition, which is mounted rwx-rwx-rwx and owned by root the Linux side so that normal Linux users can rw data on the NTFS drive.
  6. As a final note, I never worried much about sharing calendar data between Win7 and Linux and am not sure how to set it up. I in fact use google calendar, installed separately(google provider) in Tbird under Win7 and 11.3/4. So Google in fact provides the event sharing and single calendar database.

I use Google Calendar and CalDAV to share calendar data between multiple PCs (mostly Linux, both OpenSUSE and Mint, but also XP & 7) using T’bird/Lightning and also with my smartphone (iPhone). For anyone who hasn’t tried this there are several excellent howto’s provided by google. Links are at Get Started with CalDAV - Google Calendar Help

But if you have separate profiles for each OS, why do you need to have them on a shared partition anyway? Are you trying to share the mail folders or what?

Good question. The Win7 profile folder and the MAIL folder need to be on the NTFS partition in order to be accessible when Tbird on Windows is running. I put the Linux profile folder there simply as a housekeeping strategy. The NTFS partition is mounted at boot to be fully accessible by all Linux users, as I save a lot of files there that might be needed while either OS is running, at least it was when I originally set up with 11.3. I am still investigating

My goal - have the email folders always current on the PC, including all email itmes stored in the folder structure, no matter which OS I was running.

I am surprised that no one has mentioned IMAP here.

Perhaps I should have added that I want the folders current whether on-line or offline.
I use the Tbird Folder structure as a “filing system” of sorts.
Also, my primary mail interface is, which at the time did not support IMAP.

And, for completeness, I’ll admit that I am also transitioning from dual-boot to Win7VM (via VBOX) as the preferred solution for accessing the few programs left that I need/use Windows for. Once I am fully transitioned, I will only use Tbird-Linux and the need for this arrangement will be filed away.

Following up on my suspicions, I have found a fix for my problem but do not fully understand it. Perhaps a file system guru will jump in and expand on what follows.

When I first set up my 11.4 system (new install of 11.4 for /, reuse /home), I entered the following line in fstab to mount my windows drive

/dev/disk/by-id/ata-FUJITSU_MHZ2320BH_G2_K618T882G161-part1        /windows/C      ntfs-3g user,uid=*myusername*,gid=users,fmask=113,dmask=000,locale=en_US.UTF-8 0 0 

With this mount, /windows/C is owned by myusername, users dwrxwrxwrx .
I had full rwx access to the Windows partition as I wanted/needed and all seemed well.

However, experimenting, I determined that the lightning add-on would not properly install and run when the Thunderbird profile folder was located on this /windows/C partition, but would when I allowed a default Thunderbird profile to be set up in /home/username/.thunderbird.

I looked back at my 11.3 setup notes, and then changed /etc/fstab to

/dev/disk/by-id/ata-FUJITSU_MHZ2320BH_G2_K618T882G161-part1     /windows/C      ntfs-3g defaults 0 0 

With this mount, /windows/C is owned by root,root dwrxwrxwrx .
With the /windows/C partition mounted this way, lightning and google calendar provider installed, configure and run OK.

Other Tbird add-ons (e.g. view:about) had loaded and installed OK with the first fstab, so I am unclear as to why lightning would not.
I did observe that with the first fstab setup, lightning would install but would not properly configure and would not uninstall. I found in a file in the Tbird profile folder named extensions.log a number of error messages.