Thunderbird fonts

I tried adjusting the fonts in Thunderbird preferences, but it seems that whatever I set only applies to the actual message and not the listings in my inbox, sent, etc. Some advice would be appreciated.

Thanks.

On 03/11/2011 02:06 AM, ionmich wrote:
>
> I tried adjusting the fonts in Thunderbird preferences

when you say “adjusting the fonts” do you mean font size?

i don’t know if this will work for other font attributes (color,
typeface, etc) but the trick is that you have to install a add-on
because TBird has no built in way to change font in other than the
messages themselves…

i don’t remember all about exactly how, but i learned through a trip
to the knowledge base accessed from the menu Help > Help Contents,
which caused my Firefox to open on a mozilla support site…then use
the search function there…

oh, i see i have a TBird add-on named “Mail Tweak” but as i recall you
really need to find the step-by-step of what to do in Mail Tweak to
get the affect you wish…as i recall, what to do exactly, is NOT
obvious…

good luck…


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

11-03-2011 03:06, ionmich yazmış:
>
> I tried adjusting the fonts in Thunderbird preferences, but it seems
> that whatever I set only applies to the actual message and not the
> listings in my inbox, sent, etc. Some advice would be appreciated.
>
> Thanks.
>
>

If you install a theme, font with change accordingly as far as I know.
But it is up to you if you willing to change whole theme, just for
changing fonts.

I tried the tips is this knowledge base article, but decided to go back to default settings Pane and menu fonts - MozillaZine Knowledge Base. YMMV.

Here’s a solution.

Create a directory called “chrome” under the “*.default” directory that resides under the “.thunderbird” directory in your home directory. Create a file called “userChrome.css” composed of something like…

/*

/* Added manually to fix Mozilla fonts */

  • {
    font-size: 14pt !important;
    font-family: “Adobe Courier”, Serif !important;
    }

Font size and family can now be adjusted according to your liking by editing the file.

ionmich:

Did you also notice an “irregularity” with Firefox fonts also?
I have just installed 11.4 w\FF4 and some fonts render funny in the browser and Tbird 3.1.8

The letters M and F seem to be “clipped” (rendered strangely) while typing but normalize after pressing tab (auto-complete does it thing).

Just curious.

n/m. Switching to another theme corrected the issue.

Thank you.

or so I thought.

Sigh…

I see also ugly font in Firefox, Thunderbird and Chrome in menus. Font in konqueror is fine. Is there any option to unify fonts across applications? Screenshot

KDE-systemsettings → Appearance → GTK-styles and fonts. I am on a german KDE here, so I am not sure about the exact names of the respective modules, but you should find that setting easily.

Yes, I know that place for gtk theme under KDE4, but which font is to use instead of the default ‘Sans Serif’ that works fine under KDE? I use the same fonts and get to the same result as shown in the above screenshot by helgast.