Thunderbird fails to copy to INBOXSent after other updates

I’m having an issue with Thunderbird 24.2.0 on openSUSE 13.1 which appeared after my latest update which included the OpenSSL security fix and the latest LibreOffice bits (there was one other security update this weekend.) Now instead of appending sent messages to INBOX<separator>Sent it is attempting to append to INBOXSent with no separator after successfully sending the message. It either hangs indefinitely or if I select “Cancel” the original sending window appears with all menus, controls and text greyed out. If I right click in the part of the window with the body of the message the Undo, Copy and Select All options are available and all other options are greyed out.

When I go to the account preferences the option to use the Sent folder under my mailbox is selected but the second option is INBOXSent@&lt;mydomain&gt;.com. I tried changing the selection around in case the configuration was corrupted but that didn’t affect anything.

Previous usage of this machine has correctly copied files to the Sent folder.

The only oddball configuration change (made long before this problem appeared) was to set “mail.server.default.check_all_folders_for_new” to “true” as I use sieve to file mail in folders before they are retrieved by IMAP.

I haven’t seen anything here or on the general Internet about this. I can use the Select All and Copy to get a copy of the message and send it to myself, but this isn’t a long term solution. Is there another way to try to reset the configuration where it might use the correct separator and properly maintain copies of sent mail?

I have Tbird 24.0.2 running on 13.1/KDE 4.12.1.
I just ran the update you reference, that included libreoffice and openssl and a few others.

My Tbird is set up to manage several POP3 accounts plus several gmail IMAP accounts as well.
I spend most of my time in the POP3 accounts, so had to read and reread your post to understand what your objective is.

I believe this is correct - You want your copies of sent mail to be stored on the IMAP server, not locally in your Thunderbird profile folders.

I have my IMAP accounts set to save sent mail on the IMAP server as well.
When I open Edit-Account Settings for my IMAP account and look in Copies and Folders,
I have

**When sending messages, automatically:**
   [check] Place a copy in:
              [radio button] Other:  Sent Mail on ***myemailaccount***  from a drop down menubox

I checked before and after the update sending frrom Gmail to POPmail and see the sent copy being properly placed on the IMAP server.

So my Tbird is still working properly.

It has been a long time since I created this setup, so I am not sure how I entered the setting, I have to assume it was an option in the drop down menu.

Using thunderbird a bit more reveals that the separator is missing on attempts to write to the Drafts folder as well (it’s failing to write the INBOXDrafts instead of what is likely INBOX/Drafts.)

It can still get new mail, so the retrieving side seems to be using the separators correctly to access the mailboxes, it just can’t write to them.

OK, we are in a place where I can’t provide much specific help.
My first observation would be that the updates you mentioned (libreoffice, OPENSSL) did not trash MY Thunderbird so MAY not have caused this with yours, either.
Way too many moving parts in these setups to come up with a definitive “do this, do that”.

My IMAP provider (only one I use) is Gmail.
Perhaps your provider changed something to confuse your setup?

All the set up parameters are stored in one of several .js files under /home/user/.thunderbird/yourprofile/
You could look about there for something useful, but dangerous to start changing parameters.

Here is another experimental path

  1. Create a new user on your system
  2. Login as that user
  3. For that user, start with a "clean’ thunderbird setup (a.k.a. profile) and see if you can establish a connection for this new_user to your IMAP account. Specifically, do the menu options on setup look more logical.
  4. And, perhaps, leave mail.server.default.check_all_folders_for_new
    with its default (I think) value of false, just to see if in fact that is a contributor to your problem. I have a general idea what you might be doing, but have never implemented the pre-load you are doing.

Good luck