Thunderbird email links don't work

After Googling Thunderbird, I can see that Thunderbird has long had a problem opening web pages in Firefox when a email link is clicked.

I’ve been using Thunderbird 2 with the Lightning add-on in 11.0 without problems.

I’ve just upgraded from openSuse 11.0 to 11.2. Opensuse 11.2 forces you to use Thunderbird 3 which doesn’t work with Lightning. I didn’t want to give up all the data I have in Lightning, so I was forced to add the Mozilla repository in YaST and install Thunderbird 2 and Lightning. Voila, the email links don’t work. I see the exact same behavior on both my laptop and PC installations.

I use KDE, not Gnome.

The feedback from Googling on this problem isn’t good. There are a lot of different ideas and guesses at a solution, but no follow through and no real solution that I can see. This problem has been popping up as early as 2006 and has continued being reported since.

Any new ideas?

Please look here:

I think the instructions given are for Thunderbird 3 as the menu selections are different in Thunderbird 2. This is what I was able to do.

Using, Thunderbird 2. Navigate to Edit → Preferences → Advanced → General and click on the Config Editor button. I was then able to set the following:

network.protocol-handler.warn-external.ftp user set boolean true
network.protocol-handler.warn-external.http user set boolean true
network.protocol-handler.warn-external.https user set boolean true

Using Thunderbird 2, all I can do is close the Config Editor and navigate to the Thunderbird’s menu and select Tools → Add-ons and click on the Get Themes link. An External Protocol Request box opens with the Application pre-selected as “epiphany”. Epiphany will open from the link if I say okay. However, I can’t change from epiphany to firefox in this menu and can’t find anywhere else to do it either. I’ve run gnome-control-center from a terminal and tried changing the selection of which Web Browser to open from Preferred Applications and also from KDE’s Configure Desktop → Web Browser without success.

I’m happy to say that I’m one step closer, in that a web browser is opened when a link is clicked in Thunderbird 2; it just isn’t Firefox.

From the time on thunderbird was asking what to do just switch to the folder / then to /usr/bin/ in that folder you can find firefox and select that. Is really easy, isnt it?

Sorry can you use the version of thunderbird which is shipped with opensuse 11.2? openSUSE comes with 3.04b.

Hi all,

After reviewing Novell Bugzilla, this could be a packaging problem with the GNOME packagers.

I have found the easiest fix that is recommending.

The following steps are as follows:

Open konsole or xterm and type in the following first line:

gconftool-2 -s /desktop/gnome/url-handlers/http/command '/usr/bin/firefox %s' --type String

Press the [enter] key.

Type in the next line below:

gconftool-2 -s /desktop/gnome/url-handlers/https/command '/usr/bin/firefox %s' --type String

Press the [enter] key again.

Close konsole or xterm and restart Thunderbird.

  • Navigate to Tools → Add-ons and click on “Browse All Add-ons”
  • You will now see Firefox launch every time including Help Contents, Release Notes, What’s new or any " html " link

It works!!

Yes, it would be easy, if there were a means of doing that. Thunderbird 2 doesn’t give you the ability to change the web browser to use in the External Protocol Request pop-up.

No, I can’t use Thunderbird 3 for the reasons given above in my original post. I’d like to, but it isn’t an option for me. I think a lot of folks aren’t going to want to go to Thunderbird 3 for the same reasons.

When Thunderbird 3 eventually integrates the Lightning add-on, everyone’s life will be a little easier. That may not be for a long time. In the meantime, if I want to use openSuse 11.2, I have to put up with Thunderbird opening email links in the Epiphany web browser.

The alternative is to go back to openSuse 11.0 where Thunderbird 2, Lightning and Firefox all work together. Krusader and 7zip work there, too. I tried a lot of distros, but I always went back to 11.0 for a stabile work environment. I got a lot of work done in 11.0. Uh-oh, I’d better stop thinking like that or I’ll be re-installing 11.0 soon.

I’m sorry to say that it doesn’t work for me. I can’t do this:

Navigate to Tools –> Add-ons and click on “Browse All Add-ons”

I don’t have a, “Browse All Add-ons” to click on. I think it must be that these instructions are for Thunderbird 3 and I am running Thunderbird 2.

I followed the instructions as closely as possible, but didn’t see any difference in how Thunderbird reacts to an email link being clicked.

I retried the instructions you gave and they worked this time. The difference was that the second time around I didn’t try to run them as root (which means the first time around I didn’t really follow the instructions, did I.)

Anyway, when I got to the point where I was expected to click on, “Browse All Add-ons”, I clicked on, “Get Extensions”, instead. The External Request Protoype pop-up had the “/usr/bin/firefox %s” application selected, which I accepted and Firefox opened.

Thank you and everyone else who helped get this working.

For the next person to read this thread, these are the final instructions that worked for me. I just used “Get Extensions” instead of “Browse All Add-ons” in Thunderbird 2. Also, I don’t know if the instructions for “Config Editor” are really required.

They are required if you dont have gconf installed.

Thanks worked for me in 3.0b4!

worked for me as well… There is a window that pops up - choose application, only epiphany was the only option, you have to manually path to firefox ( /usr/bin/firefox)


I’m in the exact same situation with the same problem as the original poster (waiting for Lightning integration with TB3 before upgrading from TB2) and this solution worked for me! I think that enabling the warnings and remembering my link handling choice was the key as I had trying setting the string to firefox with no luck. Huzzah!