Thunderbird crashes when attaching file

Since yesterday, Thunderbird has started a new habit of disappearing into thin air when I click on Attach file. Has anyone else come across this? A Google search only reveals a few references to similar crashes some time ago running under XP. I’m asking here first because I can’t recall changing anything at all in my email configuration recently so it might be Linux. openSUSE, or KDE4-specific. Attaching a file by drag-and-drop still works.
Running KDE 4.3.2, OSS 11.1.

I experienced the same problem with Thunderbird on openSUSE 11.1 / KDE 4.3.1 recently. It wasn’t only Thunderbird. Whenever I tried to browse for a file from the webBrowser (when using gmail), the window crashed just the same. The weird thing was that I have 3 machines all with openSUSE (same configuration) but only one of my machines had the crashing problem. I deleted my Thunderbird profile thinking my profile was corrupt. That didn’t help. It wasn’t until I completely uninstalled Thunderbird and Firefox and did a fresh install of both that the problem finally went away.

Not exactly sure what caused it to happen on just that one machine, but a reinstall fixed it.

Thanks for that, at least I’m not the only one! As 11.2 is imminent, I’ll probably struggle on and simply attach files to outgoing messages using drag-and-drop for now, as 11.2 will mean a fresh install anyway. Unless, that is, someone comes up with a specific solution in the meantime…

Actually, on closer inspection drag-and-drop also doesn’t work… It appears to work, but all I get in a test message sent to myself is the filename mixed in with my signature, and no attachment. Looks like I might have to reinstall, or just use Gmail IMAP through a browser until 11.2 comes out. Or switch to 11.2 RC right now…

Re-installation would be completely unnecessary.
Run thunderbird by starting it from a terminal and watch the error when it crashes.
Where is you TB package from?

I have TB 3.0 beta 4 in Fedora and no problem

OK, here’s the terminal output:

hgm@linux-3y62:~> thunderbird
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

(gecko:30518): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorHal: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
/usr/bin/thunderbird: line 134: 30518 Segmentation fault $MOZ_PROGRAM “$@”

I’m using, from the openSUSE Build Service.

Not sure what your problem is here.
I’m not using Mozilla repo ATM because I’m RC2, but when I do use it I don’t necessarily have packages supplied solely by Mozilla, but some may be from Updates. I have never had issue doing it this way. For me Updates and Mozilla would typically have the same priority, but AYK if Updates has a newer package ver than some in Mozilla, you can end up with a supply of packages from different repos.

I hadn’t done an update of any Mozilla stuff for ages before this problem reared it head, a few days ago. I then did a Thunderbird update to see if it would help but it didn’t.

Are there any packages showing blue or red in the mozilla repo view?

Only Lightning which I didn’t bother to update as I don’t use it.

Try a new .thunderbird folder
A pain and unlikely to be the issue, but worth a go. Keep your current folder though, just rename it _old

Thanks for the suggestion but I don’t think I can be bothered. I’ll just switch to gmail in a browser when I have to attach files to an outgoing message, until I install 11.2. Life’s too short…