Thunderbird and Date Format

Just doing some filing and sorting out my system. I have a backup of my previous Thunderbird profile which includes a couple of local folders of messages from previous years. Rather than swap profiles I want to transfer these to my new profile. To do this I am moving the local folders into my active account folder so that the contents are uploaded onto IMAP server. I shall then change profiles and be able to save them in local folder in new profile.

So far I have been able to upload all the messages so they are all now on IMAP server, but for reasons I do not understand, the date format for the messages that had been in the Local Folders has changed from DD/MM/YYYY to MM/DD/YYYY on those messages that have been saved previously.

Not a big deal but it would be good to have all dates in the same format. Does anybody have any ideas why they have changed for the Local Folders? AFAIK my machines have always been set up for UK locale etc.
Budgie2

The way Thunderbird displays dates depends solely on the system locale, so definitely go check that. I don’t think any application-specific settings affect this at all. I wouldn’t blame Thunderbird, it simply shows what the system tells it to show.
But note that there can be separate and different locale settings for the system language, input layout, date format, numbers and currency etc. So even if the language fits, the rest still must be checked too.
How to do it depends on your desktop environment.

Yes, understood thank you. My question is because all the messages are now on the same IMAP account but two folders were showing the US format for the date and the rest the UK format. Very odd. My date and time format on desktop are set to UK format.

Hi Budgie,
please check that your language specific settings are also included in ~/.profile (when X Starts it uses this value – possibly Thunderbird also . . . ) plus the KDE/GNOME location specific settings. Extract from my ~/.profile:


# Most applications support several languages for their output.
# To make use of this feature, simply uncomment one of the lines below or
# add your own one (see /usr/share/locale/locale.alias for more codes)
# This overwrites the system default set in /etc/sysconfig/language
# in the variable RC_LANG.
#
export LANG=de_DE.UTF-8 # uncomment this line for German output
#export LANG=fr_FR.UTF-8        # uncomment this line for French output
#export LANG=es_ES.UTF-8        # uncomment this line for Spanish output

Cheers
DCu

Hi and thanks for the CLI command. I now find that Thunderbird takes its date short format setting from the System Language setting not the system date and time setting nor the Desktop Locale environment.
I had forgotten when I did the original installation that I left the language as EN-US because I have a US keyboard and there were some issues reported with the installation a while ago if language was changed from default.
All OK now.
Thanks again.
Budgie2