Thunderbird 45.8 schlägt fehl (weil schon 52.1 installiert ist)!)

Guten Morgen allerseits,

habe hier eine Installation mit LXDE-Desktop, wo bereits Thunderbird 52.1 installiert ist. Das automatische Update schlägt jetzt dauernd fehl, weil mir noch das alte Thunderbird 45.8 angeboten wird. Damit wird der gesamte Prozess (leider auch die ganzen anderen Updates!) abgebrochen.

Was muss ich tun, damit die Updates bei mir wieder laufen?

Besten Dank,
Fips

Sehe gerade: das Problem betrifft genauso Opera und Open_JDK, wofür ebenfalls jeweils veraltete Versionen zum Update bereit stehen.

Schönen Sonntag,
Fips

Das Update wird deinerseits wie ausgeführt? Was geschieht, als Root/su ausgeführt, bei einem

zypper -vv up

? Ausgabe?

Welche Repositorien sind eingebunden? Ausgabe von:

zypper lr -d

Ich weiß nicht, wie das Programm heißt, dass da im Hintergrund läuft? Es zeigt sich in Form eines roten Sterns in der Taskleiste!

Was geschieht, als Root/su ausgeführt, bei einem

zypper -vv up
Ausführlichkeitsgrad: 2
Ziel wird initialisiert
Es wird überprüft, ob die Metadaten für Haupt-Repository (NON-OSS) aktualisiert werden müssen
Abrufen: http://download.opensuse.org/distribution/leap/42.2/repo/non-os[fertig]
Abrufen: http://download.opensuse.org/distribution/leap/42.2/repo/non-os[fertig]
Es wird überprüft, ob die Metadaten für Aktualisierungs-Repository (Nicht-Open-Source-Software) aktualisiert werden müssen
Abrufen: http://download.opensuse.org/update/leap/42.2/non-oss/repodata/[fertig]
Es wird überprüft, ob die Metadaten für Haupt-Repository (OSS) aktualisiert werden müssen
Abrufen: http://download.opensuse.org/distribution/leap/42.2/repo/oss/co[fertig]
Abrufen: http://download.opensuse.org/distribution/leap/42.2/repo/oss/me[fertig]
Es wird überprüft, ob die Metadaten für Hauptaktualisierungs-Repository aktualisiert werden müssen
Abrufen: http://download.opensuse.org/update/leap/42.2/oss/repodata/repo[fertig]
Es wird überprüft, ob die Metadaten für google-chrome aktualisiert werden müssen
Abrufen: http://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/re[fertig]
Es wird überprüft, ob die Metadaten für Libdvdcss Repository aktualisiert werden müssen
Abrufen: http://opensuse-guide.org/repo/openSUSE_Leap_42.2/repodata/repo[fertig]
Es wird überprüft, ob die Metadaten für Packman Repository aktualisiert werden müssen
Abrufen: https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_4[fertig]
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Auflösung erzwingen: Nein

Die folgenden 27 Paketaktualisierungen werden NICHT installiert:
ffmpeg
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
gstreamer-plugins-bad-lang
1.8.3-5.5.4 noarch Packman Repository
http://packman.links2linux.de
libavcodec57
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libavdevice57
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libavfilter6
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libavformat57
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libavresample3
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libavutil55
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libFLAC++6
1.3.2-3.1 x86_64 Packman Repository
http://packman.links2linux.de
libFLAC8
1.3.2-3.1 x86_64 Packman Repository
http://packman.links2linux.de
libgstadaptivedemux-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstbadaudio-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstbadbase-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstbadvideo-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstbasecamerabinsrc-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstcodecparsers-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstgl-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstmpegts-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstphotography-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgsturidownloader-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libgstwayland-1_0-0
1.8.3-5.5.4 x86_64 Packman Repository
http://packman.links2linux.de
libmjpegutils-2_0-0
2.0.0-18.3 x86_64 Packman Repository
http://packman.links2linux.de
libpostproc54
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libquicktime0
1.2.4cvs20150223-8.3.1 x86_64 Packman Repository
http://packman.links2linux.de
libswresample2
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
libswscale4
3.3-6.8.1 x86_64 Packman Repository
http://packman.links2linux.de
mjpegtools
2.0.0-18.3 x86_64 Packman Repository
http://packman.links2linux.de

Keine auszuführenden Aktionen.

? Ausgabe?

Welche Repositorien sind eingebunden? Ausgabe von:

zypper lr -d
Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.

| Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst

—±--------------------------------±--------------------------------------------------------±----------±----------------±---------------±----------±-------±-------------------------------------------------------------------------±------
1 | download.opensuse.org-non-oss | Haupt-Repository (NON-OSS) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/ |
2 | download.opensuse.org-non-oss_1 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/ |
3 | download.opensuse.org-oss | Haupt-Repository (OSS) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/oss/ |
4 | download.opensuse.org-oss_1 | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/oss |
5 | google-chrome | google-chrome | Ja | (r ) Ja | Ja | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
6 | openSUSE-42.2-0 | openSUSE-42.2-0 | Nein | ---- | ---- | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-PHILIPS_SPD6005T |
7 | opensuse-guide.org-repo | Libdvdcss Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.2/ |
8 | packman.inode.at-suse | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.2/ |
9 | repo-debug | openSUSE-Leap-42.2-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/ |
10 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/ |
11 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/oss/ |
12 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/non-oss/ |
13 | repo-source | openSUSE-Leap-42.2-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/ |
14 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |

Stell einmal alle Pakete auf Packman um:
Als root:

zypper mr -p 20 https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.2/

Das stellt die Priorität für packman auf 20 (höher als die anderen Repos)

zypper dup --from https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.2/

Das stellt alle installierten Pakete auf diejenigen von Packman um, falls vorhanden.

Und das kleine Teil in der Kontrollleiste ist das Update Applet, das macht ein
zypper patch und kein zypper up
Dadurch verschluckt sich das schon mal…

Mach mal eine rechtsklick darauf und lass nach Updates neu suchen.

Hallo Sauerland,

bin vorgegangen wie von Dir beschrieben, was die zypper-Einstellungen angeht + Rechtsklick “Nach Updates suchen”. Trotzdem schlägt die Aktualisierung immer noch fehl bzw. bricht ab mit folgender Fehlermeldung: “Subprocess failed. Error: RPM fehlgeschlagen: error: package MozillaThunderbird-45.8.0-39.1.x86_64 is not installed”-

Noch irgendwelche Ideen, wie ich zukünftig die Updates wieder zum Laufen kriege (mit yast-Aktualisierung funktioniert es übrigens auch nicht!)?

Besten Dank für Hilfe,
Felix

Nachtrag: habe gerade in yast die Fehlermeldungen für Thunderbird, openjdk und Opera “ignoriert” (gestern hatte ich es immer mit “Abbrechen” versucht). Damit liefen jetzt zumindest die restlichen Updates durch. Allerdings erscheinen die genannten drei nach Neustart immer noch in der Liste. Wie kriege ich die da raus?

Dank tschau,
Fips

Poste:

zypper ll
zypper patch
zypper se -s Thunderbird openjdk opera

Ansonsten würde ich in der Softwareverwaltung einmal die alten Versionen vorrübergehend installieren das Update durchlaufen lassen und danach die neuen Versionen wieder installieren.

zypper ll
Es sind keine Paketsperren definiert.


zypper patch
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Die folgenden 4 NEUEN Patches werden installiert:
  openSUSE-2017-542 openSUSE-2017-544 openSUSE-2017-545 openSUSE-2017-568

Die folgenden 3 Pakete werden GELÖSCHT:
  java-1_8_0-openjdk-headless MozillaThunderbird opera

3 zu entfernende Pakete.
Nach dem Vorgang werden 353,1 MiB freigegeben.
Fortfahren? [j/n/...? zeigt alle Optionen] (j): 
Überprüfung auf Dateikonflikte läuft: ..................................[fertig]
(1/3) MozillaThunderbird-45.8.0-39.1.x86_64 entfernen ..................[Fehler]
Entfernen von (39721)MozillaThunderbird-45.8.0-39.1.x86_64(@System) fehlgeschlagen:
Fehler: Subprocess failed. Error: RPM fehlgeschlagen: error: package MozillaThunderbird-45.8.0-39.1.x86_64 is not installed


Abbrechen, wiederholen, ignorieren? [a/w/i] (a): 
Während oder nach der Installation/dem Entfernung von Paketen ist ein Problem aufgetreten:
Installation aborted by user

In der Fehlermeldung oben finden Sie einen entsprechenden Hinweis.


zypper se -s Thunderbird openjdk opera

Ansonsten würde ich in der Softwareverwaltung einmal die alten Versionen vorrübergehend installieren das Update durchlaufen lassen und danach die neuen Versionen wieder installieren.

Ob ich das noch hinkriege?

F.

zypper se -s Thunderbird openjdk opera
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name                                   | Typ        | Version              | Arch   | Repository                                             
--+----------------------------------------+------------+---------------------+--------+--------------------------------------------------------
i | MozillaThunderbird                     | Paket      | 52.1.0-41.3.1        | x86_64 | Hauptaktualisierungs-Repository                        
i | MozillaThunderbird                     | Paket      | 45.8.0-39.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird                     | Paket      | 45.7.0-34.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird                     | Paket      | 45.6.0-31.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird                     | Paket      | 45.5.1-28.2          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird                     | Paket      | 45.5.0-25.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird                     | Paket      | 45.4.0-23.1          | x86_64 | Haupt-Repository (OSS)                                 
  | MozillaThunderbird                     | Quellpaket | 52.1.0-41.3.1        | noarch | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird                     | Quellpaket | 45.8.0-39.1          | noarch | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird                     | Quellpaket | 45.7.0-34.1          | noarch | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird                     | Quellpaket | 45.6.0-31.1          | noarch | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird                     | Quellpaket | 45.5.1-28.2          | noarch | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird                     | Quellpaket | 45.5.0-25.1          | noarch | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 52.1.0-41.3.1        | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 45.8.0-39.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 45.7.0-34.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 45.6.0-31.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 45.5.1-28.2          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 45.5.0-25.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-buildsymbols        | Paket      | 45.4.0-23.1          | x86_64 | Haupt-Repository (OSS)                                 
  | MozillaThunderbird-devel               | Paket      | 52.1.0-41.3.1        | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-devel               | Paket      | 45.8.0-39.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-devel               | Paket      | 45.7.0-34.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-devel               | Paket      | 45.6.0-31.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-devel               | Paket      | 45.5.1-28.2          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-devel               | Paket      | 45.5.0-25.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-devel               | Paket      | 45.4.0-23.1          | x86_64 | Haupt-Repository (OSS)                                 
i | MozillaThunderbird-translations-common | Paket      | 52.1.0-41.3.1        | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird-translations-common | Paket      | 45.8.0-39.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird-translations-common | Paket      | 45.7.0-34.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird-translations-common | Paket      | 45.6.0-31.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird-translations-common | Paket      | 45.5.1-28.2          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird-translations-common | Paket      | 45.5.0-25.1          | x86_64 | Hauptaktualisierungs-Repository                        
v | MozillaThunderbird-translations-common | Paket      | 45.4.0-23.1          | x86_64 | Haupt-Repository (OSS)                                 
  | MozillaThunderbird-translations-other  | Paket      | 52.1.0-41.3.1        | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-translations-other  | Paket      | 45.8.0-39.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-translations-other  | Paket      | 45.7.0-34.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-translations-other  | Paket      | 45.6.0-31.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-translations-other  | Paket      | 45.5.1-28.2          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-translations-other  | Paket      | 45.5.0-25.1          | x86_64 | Hauptaktualisierungs-Repository                        
  | MozillaThunderbird-translations-other  | Paket      | 45.4.0-23.1          | x86_64 | Haupt-Repository (OSS)                                 
i | Opera                                  | Anwendung  |                      | noarch | Aktualisierungs-Repository (Nicht-Open-Source-Software)
i | Thunderbird                            | Anwendung  |                      | noarch | Haupt-Repository (OSS)                                 
i | Thunderbird                            | Anwendung  |                      | noarch | Hauptaktualisierungs-Repository                        
i | java-1_7_0-openjdk                     | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_7_0-openjdk                     | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_7_0-openjdk                     | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk                     | Quellpaket | 1.7.0.131-40.1       | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk                     | Quellpaket | 1.7.0.121-37.2       | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-accessibility       | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-accessibility       | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-accessibility       | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-bootstrap           | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap           | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap           | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-bootstrap           | Quellpaket | 1.7.0.131-40.1       | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap           | Quellpaket | 1.7.0.121-37.2       | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap-devel     | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap-devel     | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap-devel     | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-bootstrap-headless  | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap-headless  | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-bootstrap-headless  | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-demo                | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-demo                | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-demo                | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-devel               | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-devel               | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-devel               | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
i | java-1_7_0-openjdk-headless            | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_7_0-openjdk-headless            | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_7_0-openjdk-headless            | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-javadoc             | Paket      | 1.7.0.131-40.1       | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-javadoc             | Paket      | 1.7.0.121-37.2       | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-javadoc             | Paket      | 1.7.0.111-35.1       | noarch | Haupt-Repository (OSS)                                 
i | java-1_7_0-openjdk-plugin              | Paket      | 1.6.2-3.3.3          | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_7_0-openjdk-plugin              | Paket      | 1.6.1-2.38           | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_7_0-openjdk-plugin              | Quellpaket | 1.6.2-3.3.3          | noarch | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-src                 | Paket      | 1.7.0.131-40.1       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-src                 | Paket      | 1.7.0.121-37.2       | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_7_0-openjdk-src                 | Paket      | 1.7.0.111-35.1       | x86_64 | Haupt-Repository (OSS)                                 
i | java-1_8_0-openjdk                     | Paket      |  1.8.0.121-10.5.1    | x86_64 | Hauptaktualisierungs-Repository                         
v | java-1_8_0-openjdk                     | Paket      |  1.8.0.121-10.2.1    | x86_64 | Hauptaktualisierungs-Repository                         
v | java-1_8_0-openjdk                     | Paket      | 1.8.0.121-8.1        | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk                     | Paket      | 1.8.0.121-6.4        | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk                     | Paket      | 1.8.0.111-3.1        | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk                     | Paket      | 1.8.0.101-1.1        | x86_64 | Haupt-Repository (OSS)                                 

zypper se -s Thunderbird openjdk opera
  | java-1_8_0-openjdk                     | Quellpaket |   1.8.0.121-10.5.1    | noarch | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk                     | Quellpaket |   1.8.0.121-10.2.1    | noarch | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk                     | Quellpaket | 1.8.0.121-8.1         | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk                     | Quellpaket | 1.8.0.121-6.4         | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk                     | Quellpaket | 1.8.0.111-3.1         | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-accessibility       | Paket      |   1.8.0.121-10.5.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-accessibility       | Paket      |   1.8.0.121-10.2.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-accessibility       | Paket      | 1.8.0.121-8.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-accessibility       | Paket      | 1.8.0.121-6.4         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-accessibility       | Paket      | 1.8.0.111-3.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-accessibility       | Paket      | 1.8.0.101-1.1         | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_8_0-openjdk-demo                | Paket      |   1.8.0.121-10.5.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-demo                | Paket      |   1.8.0.121-10.2.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-demo                | Paket      | 1.8.0.121-8.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-demo                | Paket      | 1.8.0.121-6.4         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-demo                | Paket      | 1.8.0.111-3.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-demo                | Paket      | 1.8.0.101-1.1         | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_8_0-openjdk-devel               | Paket      |   1.8.0.121-10.5.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-devel               | Paket      |   1.8.0.121-10.2.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-devel               | Paket      | 1.8.0.121-8.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-devel               | Paket      | 1.8.0.121-6.4         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-devel               | Paket      | 1.8.0.111-3.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-devel               | Paket      | 1.8.0.101-1.1         | x86_64 | Haupt-Repository (OSS)                                 
i | java-1_8_0-openjdk-headless            | Paket      |   1.8.0.121-10.5.1    | x86_64 | Hauptaktualisierungs-Repository                          
i | java-1_8_0-openjdk-headless            | Paket      |   1.8.0.121-10.2.1    | x86_64 | Hauptaktualisierungs-Repository                          
v | java-1_8_0-openjdk-headless            | Paket      | 1.8.0.121-8.1         | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk-headless            | Paket      | 1.8.0.121-6.4         | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk-headless            | Paket      | 1.8.0.111-3.1         | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk-headless            | Paket      | 1.8.0.101-1.1         | x86_64 | Haupt-Repository (OSS)                                 
  | java-1_8_0-openjdk-javadoc             | Paket      |   1.8.0.121-10.5.1    | noarch | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-javadoc             | Paket      |   1.8.0.121-10.2.1    | noarch | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-javadoc             | Paket      | 1.8.0.121-8.1         | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-javadoc             | Paket      | 1.8.0.121-6.4         | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-javadoc             | Paket      | 1.8.0.111-3.1         | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-javadoc             | Paket      | 1.8.0.101-1.1         | noarch | Haupt-Repository (OSS)                                 
i | java-1_8_0-openjdk-plugin              | Paket      | 1.6.2-3.3.2           | x86_64 | Hauptaktualisierungs-Repository                        
v | java-1_8_0-openjdk-plugin              | Paket      | 1.6.1-2.35            | x86_64 | Haupt-Repository (OSS)                                  
  | java-1_8_0-openjdk-plugin              | Quellpaket | 1.6.2-3.3.2           | noarch | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-src                 | Paket      |   1.8.0.121-10.5.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-src                 | Paket      |   1.8.0.121-10.2.1    | x86_64 | Hauptaktualisierungs-Repository                          
  | java-1_8_0-openjdk-src                 | Paket      | 1.8.0.121-8.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-src                 | Paket      | 1.8.0.121-6.4         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-src                 | Paket      | 1.8.0.111-3.1         | x86_64 | Hauptaktualisierungs-Repository                        
  | java-1_8_0-openjdk-src                 | Paket      | 1.8.0.101-1.1         | x86_64 | Haupt-Repository (OSS)                                 
i | opera                                  | Paket      |   45.0.2552.635-38.1  | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   44.0.2510.1449-35.1 | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
i | opera                                  | Paket      |   44.0.2510.1218-32.1 | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   43.0.2442.1144-27.1 | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   43.0.2442.991-24.1  | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   43.0.2442.806-21.1  | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   42.0.2393.517-18.1  | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   42.0.2393.137-15.1  | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   42.0.2393.94-12.1   | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   42.0.2393.85-9.1    | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   41.0.2353.69-6.1    | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   41.0.2353.56-3.1    | x86_64 | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
v | opera                                  | Paket      |   41.0.2353.46-1.2    | x86_64 | Haupt-Repository (NON-OSS)                               
  | opera                                  | Quellpaket |   45.0.2552.635-38.1  | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   44.0.2510.1449-35.1 | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   44.0.2510.1218-32.1 | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   43.0.2442.1144-27.1 | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   43.0.2442.991-24.1  | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   43.0.2442.806-21.1  | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   42.0.2393.517-18.1  | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   42.0.2393.137-15.1  | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   42.0.2393.94-12.1   | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   42.0.2393.85-9.1    | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   41.0.2353.69-6.1    | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)
  | opera                                  | Quellpaket |   41.0.2353.56-3.1    | noarch | Aktualisierungs-Repository   (Nicht-Open-Source-Software)

Als root:

zypper rm MozillaThunderbird-45.8.0-39.1
zypper clean -a && zypper ref
rpm --rebuilddb

Lass jetzt einmal nach neuen Updates suchen und schau, ob es dann funktioniert.

Hi,

es gab eine Fehlermeldung:

Das folgende Paket wird GELÖSCHT:
  MozillaThunderbird

1 zu entfernendes Paket.
Nach dem Vorgang werden 96,3 MiB freigegeben.
Fortfahren? [j/n/...? zeigt alle Optionen] (j): 
(1/1) MozillaThunderbird-45.8.0-39.1.x86_64 entfernen ..................[Fehler]
Entfernen von (14)MozillaThunderbird-45.8.0-39.1.x86_64(@System) fehlgeschlagen:
Fehler: Subprocess failed. Error: RPM fehlgeschlagen: error: package MozillaThunderbird-45.8.0-39.1.x86_64 is not installed


Die yast-Aktualisierung lief ansonsten fehlerfrei durch! Werde das weiter beobachten…

Vielen Dank so weit,
Felix

Und was ist mit den beiden anderen Befehlen???

So weit scheint alles geklappt zu haben! Weiß bloß nicht, wie man den Updater vom LXDE-System manuell aufrufen kann, um ihn zu testen (habe es bislang wie gesagt bloß mit yast probiert)?

F.

Da LXDE wahrscheinlich gnome-packagekit verwendet, solltest du die entsprechende GUI dazu über „gpk-update-viewer“ aufrufen können. Auf der Konsole, als Anwender und nicht über Root/su, kannst du dir die Updates, welche dir in der Leiste von LXDE angezeigt werden, über

pkcon get-updates

auflisten lassen.

Ebenfalls als einfacher Anwender kannst du die Updates mit

pkcon update

„installieren” lassen. Leider, wie du selbst schon gemerkt hast, funktioniert das nicht immer einwandfrei.

Guten Abend,

soeben lief das Update wieder sauber durch (gab übrigens schon wieder was Neues für Thunderbird)!

Vielen Dank nochmal für die tolle Hilfe,
Fips :shame:

PKCON ist leider nicht das Programm mit dem roten Stern, welches in der Taskleiste läuft!?

F.

So ist es. In der Taskleiste läuft, wie schon erwähnt, gnome-packagekit. pkcon (PackageKit console client) verwendest du in der Konsole.

ขอบคุณข้อมูลที่น่าสนใจสำหรับข้อมูลดีดี

Maxbet