Thunderbird 3 and saving attachments


at my work we have upgraded suse to 11.2, thus we also got an upgrade of thunderbird 2 to 3.

When I now save attachments to our network disks it writes them as user=rw (600), and no longer as 644. I do not want to do chmod for every attachment.

When creating a file by csh or bash terminal or downloading a file by firefox it does write the file as 644, which is good.

Can someone please give me a suggestion of how I can solve this problem? Is there something I have to change in the prefs.js file?

Best regards,

Arjan Burggraaf

Hi Arjan, welcome to the forums. Done some searching and cannot find an answer right now. I suggest you’d search the mozilla thunderbird forums as well.

It looks like this behaviour has not been fixed for a long time:

Perhaps TB2 on openSUSE had some custom mods to not override the umask.

Done some testing as well. I cannot find a setting in about:config, that changes this behaviour. On a clean setup of Thunderbird, the same thing happens here. Please file a bug report.

In the meantime you could let a script on the server change the permissions of downloaded files. Run the script through the crontab, and no manual interference is needed.

Ok, thanks for your comments.

Indeed, I can write a script that changes the downloaded files to 644. Good idea!