Three problems with Transmission

I have three separate problems with Transmission, one which comes from a mistake I made, the second I can’t understand, and the third which seems similar to the first but appeared without me doing anything that I know of.

The one coming from my mistake:
Since I don’t really understand the syntax of /etc/fstab I used mount to mount the disk partition that I use for most of my data (since my /home is too small). This partition is formatted with btrfs, if that matters.
I created a folder, DD, to mount it into. I didn’t understand that this folder would be deleted at reboot, so I launched Transmission and put this DD as the default destination for torrents.
When I discovered that the DD folder was deleted and after some confusion when I tried to mount it from Nautilus I chose to now mount it at /run/media/myusername/c**********/ with c******** being the name the system gave it automatically (its UIID maybe?).
Now all the torrents that have not completed the first time say they can’t find the data, and even when I tried moving them to the new location (the same place but with the new name, actually) they still can’t find the data.

The second appeared today out of nowhere, I needed to download a Debian ISO so I called Transmission (as torrent is the recommended download method) and began downloading, setting location as /run/media/myusername/c**********/ (the disk being correctly mounted).
And now I get an error message, “erreur: permission non accordée” (error: unauthorized access) that I can’t really understand, the rights for /run/media/myusername/c**********/ being rwxrwxrwx ?

The third appeared just now, I installed XFCE and rebooted, and now apparently I don’t have a /run/media/myusername/ folder and was able to mount the partition only to /run/media/c**********/ so even the torrents that were completed to /run/media/myusername/c**********/ say that they can’t find their data…

Why don’t you simply create a subfolder in your /home directory for your application needs?
Assuming you’re running your Transmission as a User, /home/* locations would be most natural.
If you’re running Transmission as a Server, then it might make sense to place in a subdirectory of your root…
But even in that case you should probably point to a subdirectory of your Transmission app or maybe somewhere in /opt.

Don’t point to those locations you’re trying, they’re often ephemeral (delete on shutdown).

And, why are you mounting folders?
Unless those are devices (eg external drives) which aren’t available on boot, there aren’t usually good reasons to do so.
KISS should be your motto, just point to a directory without mounting unless you have special reasons to do otherwise.


Your description of your trials to mount a file system is a bit bewildering to me (creating a directory DD, but where and it being removed on shutdown and not knowing how to use /etc/fstab). Maybe this helps:,_filesystems,_mount_points

And please do not try to use a mountpoint inside /run, his area is for system use and and also basicaly for things only to be kept during the present uptime (run) of the system and thus maybe lost after shutdown. More precise, /run/media is the place where the desktop, together with the system, creates mountpoints for a loged in user (thus the /run/media/<user> to keep those for different users apart) that connects media during his/her session. That will be cleaned up if the media is removed and in any case as the user logs out.

This is e.g. from the article the Filesystem Hierarchy Standard (FHS) in Wikipedia about /run:

Run-time variable data: Information about the running system since last boot, e.g., currently logged-in users and running daemons. Files under this directory must be either removed or truncated at the beginning of the boot process; but this is not necessary on systems that provide this directory as a temporary filesystem (tmpfs).

And creating an entry in /etc/fstab for file systems to be mounted at boot can be done using YaST > System > Partition Manager (and when the file system does already exist, like it seems to be the case here, take care that you do NOT “format” it).

I don’t have enough space in my /home for that, and yes I run Transmission as a user.
I mount partitions on folders because I don’t know what else to do to allow my filesystem to access these partitions. Is there another way (except fstab of course but it would still be mounting partitions on folders if I’m not mistaken)?
I was very surprised that they weren’t mounted on boot, Debian or Mint do that automatically, I never had to bother about it (at least if they’re not mounted they appear in Nautilus or Nemo or Caja and I just have to click on them to have them mounted).
In Debian and its derivative they are mounted in /media so I was very surprised to see that anything I plug in is mounted in /run/media as there are no /media apparently, but I just went on with it. Apparently it was a mistake?
Should I have mounted them on /mnt ?

Apparently now the partition is automatically mounted at boot in /run/media/

And the problem with the “permission non accordée” seems to come from the setting of Transmission and to be another mistake I made: in the “preferences” the option “conserver les torrents incomplets dans:” (keep incomplete torrents in:) was set to “(Aucun)” (none) which means that it tries to save them to the “Aucun” folder, not that the option was not selected.

So now it works!

But I’m still stuck with the torrents that were downloaded before and to which Transmission doesn’t know where they are, is there a way to correct that?