This site will not play its music

using Chromium Version 39.0.2171.65 (64-bit).
openSuse 13.2
It works ok with Firefox but I prefer Chromium.
I tried disabling adblock but it had no effect.
Any ideas ?

As the site seems to use Flash for the music, install the package chromium-pepper-flash.
Chromium does not support Netscape plugins any longer since quite some time already, i.e. it cannot use the standard flash-player that Firefox uses.

I had already installed pepper-flash thing and it helped with another site to be able to see the videos. However it does not help with this for some reason.

guessing you don’t like Chrome but it plays fine in Chrome-beta (41.0) and in FF 35.0, sometimes its informative to test as a different user

Then try to install chromium-ffmpeg as well. Maybe it uses HTML5 in Chromium or depending on your location?

Well, it’s working but not like before. Before, when I went to the site, I clicked on the play button and it started playing.
Now the site tries to automatically play then I have to pick an Audio menu option titled Flash Player.
After that all is well.

Thanks for your help and I can highly recommend the site for beautiful classical music.