This beep is annoying the hell out of me

Not sure this is the right place, but I don’t know where this should go. No matter what I try in order to disable the beep, it always comes back. Most commonly found when scrolling on emacs or matlab. You can’t imagine the hatred that I have for this beep.

I’m running OpenSuse 12.1, and, here’s what I’ve tried.

I put “xset -b” into .bashrc, and it works for a period of time, and then stops. Similarly, I can type it into the command line and it’ll work for some amount of time (no beeps), and then when I’m least expecting it, the beep will come back.

I tried playing with the settings in System Bell Configuration. And all I’ve managed to do is make the beep to be a more annoying sound. Setting volume to 0 does not work, and it won’t let me set the duration to 0. Usually it’s unchecked, but it still likes beeping at me for whatever reason.

I’ve added “blacklist pcspkr” to etc/modprobe.d/50-blacklist.conf and thought that my beep problems would finally be gone, and then lo and behold, 2 hours later I get another beep.

Why does this even exist and why is it so **** hard to get rid of? I’m going to remove the beep through emacs options now, hopefully I can at least silence it in that application, but I’d like to get rid of it for everything.

Yeah, I found that thread. And I mentioned that I tried those suggestions. They didn’t seem to work. At least emacs will never beep at me again now.

Can you look in alsamixer (run it from the terminal) to see whether you can configure beep in there? Here is what my alsamixer looks like with beep muted:

Was the module still loaded after having done that blacklist ?

On Fedora, its more than just ‘blacklist pcspkr’, but rather it is - as the root user, edit the file /etc/modprobe.d/blacklist.conf to add both these lines:

blacklist pcspkr
alias pcspkr /bin/true

with that saved, now make sure there’s no loaded pcspkr module (with root permissions)

modprobe -r pcspkr

The tone speaker on the board is then nominally disabled in Fedora at that point. You could try that on openSUSE.

This is normal. You should not put “xset -b” in bash startup files but in X startup script. I put it in the system wide /etc/X11/xinit/xinitrc and /etc/X11/xdm/Xsession, as well as /etc/gdm/Xsession, so it is normally disabled in X for all users. Gnome (2) used to ignored this setting. Therefore I had to disable it in Gnome too.

Disabling the bell in X and Gnome, and adding the following in /etc/inputrc for Bash

set bell-style none

and this option in ~/.vimrc for vim (I don’t use emacs):

set noerrorbells

has always worked for me on all Linux, as well as Unix. There are about 15 Linux and Unix computers here and they are not allowed to beep without a good reason (that would drive me crazy). I never disable pcspkr, and I don’t think it is a good idea (we’re not allowed to disable the fire alarm either). A computer should be able to beep to signal a serious problem, but it should of course not beep every time you press backspace. It usually suffices to mute the bell in all applications.