Thinkpad T60p Firegl V5200 screen resolution problem

Hello,
I have an Thinkpad T60p with ATI FireGL V5200 Graphics. I run Opensuse 11.2 with the radeon driver. the problem is, that if i run dualscreen, the resolution of the laptop monitor is wrong and the right option is not available, neither via sax2, nor via xrandr or the kde control center. the resolution of my vga-connected external monitor is 1680x1050, wich is also correctly used by opensuse. the internal tft has a resolution of 1400x1050 but i can only get 1280x800. I have attached my xorg.conf and the xorg.0.log, if that helps.

xorg.o.log: X.Org X Server 1.6.5 Releas - Anonymous - vFBCYL6U - Pastebin.com
xorg.conf: # /…/ # SaX generated X11 c - Anonymous - fU8ApV9z - Pastebin.com](http://pastebin.com/fU8ApV9z)

if anyone knows how to solve my problem, thanks in advance

The first thing to try is adding a modeline for your laptop display. Edit xorg.conf “Mode” section like this


Section "Modes"
   Identifier   "Modes[0]"
   ModeLine "1400x1050" 122.00  1400 1488 1640 1880 1050 1052 1064 1082 +hsync +vsync
EndSection

See how that goes.

Hi, thanks for your suggestion, but it isnt working. Only thing it changes is setting the external monitor that has 1680x1050 to 1400x1050 by default, so i need to change it to look normal. the external monitor is/was working perfectly, only the internal one isnt working. if i use only the internal one, the resolution can be set to 1400x1050.

Well that was a surprising result! Almost as if your monitor sections are transposed. Manual modes can be included in each monitor section, and can be generated with the gtf CLI utility if desired.

I would have a look at man radeon for more information concerning configuration options.

BTW, I always thought (but maybe its not the case) that a virtual line was required (in the screen section) for this kind of dual head setup:

Virtual 3080 2100 

Not sure what to suggest next. Can you post the output of ‘xrandr’ with both displays active?

Ok, I think I may have found the problem. You have

Option “monitor-LVDS” “EXT”

in your device section, so the laptop display (LVDS) is referenced by the “EXT” monitor section (your second monitor section). If I understood your xorg.log file correctly, you have an external monitor plugged in via a VGA port (not the DVI port). There should be entries to define which monitor is configured with each monitor section like this:

Option “monitor-LVDS” “Monitor[0]”
Option “monitor-VGA-0” “EXT”

Then your monitor sections should work as expected.

I gleaned this info while trawling with google and reading this thread and this blog.

Ok that changed something :slight_smile: Now my Laptop Monitor is right resolution 1400x1050 but my external monitor wont go up to more than 1024x768, but it has 1680x1050…
Here is what xrandr says if that helps:

Screen 0: minimum 320 x 200, current 2424 x 1050, maximum 3840 x 1200
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 474mm x 297mm
1024x768 60.0*
800x600 60.3 56.2
640x480 59.9
LVDS connected 1400x1050+1024+0 (normal left inverted right x axis y axis) 287mm x 215mm
1400x1050 60.0*+ 50.0
1280x1024 59.9 60.0
1280x960 59.9
1280x854 59.9
1280x800 59.8
1280x720 59.9
1152x768 59.8
1024x768 60.0 59.9
800x600 60.3 59.9
640x480 59.9
DVI-0 disconnected (normal left inverted right x axis y axis)

ok i got it to work. i changed the xorg.conf and xrandr showed that the right resolutions for both monitors where available. so everytime i want to view extended desktop view, i use the following script i wrote:
#!/bin/sh
xrandr --output LVDS --auto
xrandr --output VGA-0 --auto --left-of LVDS

thanks deano for helping :slight_smile:
wwhat would be absolutely great, if someone said me what to change if i want mirror mode with xrandr.

Indeed ! deano_ferrari many thanks for passing on your expertise here!

Ok that changed something Now my Laptop Monitor is right resolution 1400x1050 but my external monitor wont go up to more than 1024x768, but it has 1680x1050…

I wasn’t surprised by the external monitor resolution, as I could see more changes probably required concerning the external monitor section in your xorg.conf. In particular, the horizontal sync range is too low for 1680x1050. It should have been more like

HorizSync 31-70

I guess you’ve made those adjustments now. In fact, they’re not required for new display devices generally.

wwhat would be absolutely great, if someone said me what to change if i want mirror mode with xrandr.

Do you mean clone mode? If so, I believe clone mode can be set with something like:

xrandr --output LVDS --auto --output VGA-0 --auto --same-as LVDS

or

xrandr --auto --output VGA-0 --mode 1680x1050 --same-as LVDS