Thinkpad T60 Fn keys and global shortcuts

Hello,

I have been using Gnome for a while now, and it works without problems on my Thinkpad T60. However, I am not a fan of what I have seen of Gnome 3, and so I thought I would give KDE a try. I installed the KDE(4.6.0) pattern from software management, and now I can log in on to the KDE desktop environment as well as Gnome. A couple of thinkpad specific things don’t work however. Some of the thinkpad hotkeys don’t work. In particular the Fn+F12 (hibernate) and the audio controls on the arrows. Pressing these combinations has no result. The keyboard is set to IBM Thinkpad R60/T60 etc in keyboard settings. Running xev from console shows KDE recognises the key presses, and even that they are registered as having the function they are intended to.

Here is the xev output for Fn+12:

KeyPress event, serial 34, synthetic NO, window 0x5e00001,
    root 0x157, subw 0x5e00002, time 8771089, (47,22), root:(49,45),
    state 0x10, keycode 213 (keysym 0x1008ffa7, XF86Suspend), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 34, synthetic NO, window 0x5e00001,
    root 0x157, subw 0x5e00002, time 8771089, (47,22), root:(49,45),
    state 0x10, keycode 213 (keysym 0x1008ffa7, XF86Suspend), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False


I thought that this might be a keyboard shortcut settings issue. In System Settings -> Shortcuts and Gestrures -> Global Shortcuts the ‘KDE Daemon’ shortcuts has Hibernate listed with the global shortcut. If I change that setting from the default, and enter Fn+F12 as the ‘new’ shortcut then the computer will hibernate. However, it does not save this across sessions. After logging out and logging back in the key won’t respond again. I have tried setting a different key combination, Ctrl+F12, and again it worked in the session, but the change was not saved. After logging back in it had reset to the unresponsive default.

The audio controls I can probably live without, but the lack of a shortcut for hibernation is not great. Any advice on the matter would be much appreciated.

Thanks in advance.

Just to be clear there are two possibly related issues - though I don’t know enough to say if they are.

  1. Not all the Fn keys work on my Thinkpad T60. People had problems with IBM/Lenovo hotkeys in KDE a while back, but I have not found anything recent about it (does this mean this was more or less fixed?). So, how can I get them working, in particular the Fn+F12 key, and the audio controls?

  2. Global shortcuts are not saved in KDE. I can set a global shortcut (like changing the shortcut for hibernation), but the changes are not saved from session to session. How can I get global shortcuts to stay saved from session to session?