Thinkpad T430 BIOS update without installed Windows

From disks created by OS, (Leap 15.0 install, Leap 15.0 KDE Live) I am trying to install/use Leap 15 on a Thinkpad T340 with a new SSD drive w/no OS. From the KDE Live disk, it dies following the appearance of the openSUSE logo. From the KDE Live Safe boot option, I can get to a cmd prompt, but don’t know where to go from there.

Welcome to openSUSE Leap 15.0 - Kernel 4.12.14-lp150.12.4-default (tty1)
localhost login: _

From the Leap 15 Installation disk, selecting the Installation option from the boot screen:

Loading Linux Kernel…

>>>openSUSE Leap 15.0 installation disk v5.1.11…
Starting udef…ok

then no DVD read activity

From the Installation Safe option gets me to:

>>>openSUSE Leap 15.0 installation program v5.1.11…
Starting udef…ok

then no DVD read activity

I suspect this may be a problem with BIOS. I’ve tried to update the BIOS from the Lenovo site, but it appears that Lenovo has had an MS lobotomy and does all BIOS type updating from within Windows. I can see the current UEFI BIOS version as G1ETB2WW (2.72) 2017-01-31. The Lenovo BIOS update page shows:

BIOS Update (Bootable CD) for Windows 10 (64-bit), 8.1 (32-bit, 64-bit), 8 (32-bit, 64-bit), 7 (32-bit, 64-bit), XP - ThinkPad T430, T430i

but I won’t be using any of those OSs and it appears that the BIOS may be OS-specific. Since wrong BIOS updates can leave a machine incapacitated, I am hesitant to start that process without knowing that openSUSE 15 will be able to be installed or even used with a live DVD version.

Did you not find the following or similar language when searching for a BIOS update on

The BIOS Update CD can boot the computer disregarding the operating systems and update the UEFI BIOS (including system program and Embedded Controller program) stored in the ThinkPad computer to fix problems, add new functions, or expand functions as noted below.

That means the file to download is used to create bootable media to update the BIOS, a file which is independent of any installed OS. It does not depend on there being any installed OS, regardless of source. I copied and pasted it from Indeed, it should be able to be used even with all HD and/or SDD devices removed from the laptop.

The prominent inclusion of “Windows”, and “operating system” as used, on that page is very misleading. CD .isos don’t require “support” in any form. What they probably mean is “don’t contact us for help if you can’t figure out how to turn this .iso into a bootable CD and update your BIOS with it”.

Thanks, I hadn’t found this and appreciate the clarification. I have downloaded the .iso file, but I can’t seem to find a way to extract the contents in either an earlier version of openSUSE or in Windows 7. In openSUSE, the right click menu does have an extract action, but using it does not result in an extraction. In W7, the right click menu does not include extract. I’ve tried that on the original downloaded file on the HD and on the copy of the file on a USB key which I hoped to make bootable.

Some incidental information. An Ubuntu 18.1 live disc did boot the T340, though the openSUSE 15 live disc didn’t. openSUSE live creates an animated logo–diagonal diamond and an open V. Eventually the animation stops with “Leap” under the icon, but nothing happens after that and the keyboard and mouse are inactive.

.iso files are ready to write to target media, not “extracted”. should be as much media creation instruction as you need for both your Lenovo BIOS update, and installing Leap.

Correction: It is a Thinkpad T430.

I’ve resolved the problem, but not according to information above. To clarify:
I have two Thinkpad T430s. T430/1 with BIOS G1ETB1WW (2.71) running Window 7 and
T430/2 with BIOS G1ETB2WW (2.72) with a blank 1Tb SSD (with Preinstalled OS License Win8 Pro DPK TPG)

I wanted to install openSUSE 15.0 on T430/2.

I purchased from three versions of openSUSE 15.0 - Leap 15.0 Installation, Leap 15.0 KDE Live and Leap 15.0 Rescue.

Running Leap 15.0 Installation and 15.0 KDE Live ended in the executions dying at the Leap logo - diamond inside a V.
I suspected a BIOS problem, but had difficulty getting the Lenovo BIOS update executable to load.

I loaded Leap 15.0 KDE Live on a ThinkCentre successfully, which proved the integrity of the disks.
I repeated this on T430/1 successfully.

Finally I swapped in the blank 1Tb SSD drive to the T430/1 and ran the Leap 15.0 Installation successfully, then removed the SSD and installed it in T430/2 which booted with its original; BIOS v. G1ETB2WW (2.72)

I no longer think this is a problem with the BIOS in T430/2, but there is something which is preventing either the Install disc or the Live disc from booting the machine.

I leave these track for other T430 users who may be trying this installation.