Thinkpad T410 - Fn+light not working

Installed opensuse 11.4 KDE into my Thinkpad T410.

Noticed that pressing Fn+Home(+brightness) and Fn+End(-brightness) has no effect to the brightness setting at all.

Any idea what I should set?

Have been quite some time now, anyone comes across a solution?

I remember a thread on this topic (but openSUSE 11.3):

OpenSUSE 11.3 Lenovo T410 Brightness Control Not Working

Do you have the ‘thinkpad-acpi’ module loaded?

lsmod | grep thinkpad

More on this here:

Thinkpad-acpi - ThinkWiki

Thinkpad acpi seems to be loaded

lsmod | grep thinkpad

thinkpad_acpi 79409 0

But brightness control still not working:(

Update for future users:

Out of frustration, I did something that others had done but found it not effective

kdesu nvidia-xconfig

this creates the file /etc/X11/xorg.conf

then edit this file in terminal
vi /etc/X11/xorg.conf

adding *** Option “RegistryDwords” “EnableBrightnessControl=1”***

effectively the affected section looks like this



Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “RegistryDwords” “EnableBrightnessControl=1”

Section “Screen”


reboot and brightness control works !! :smiley:

Hope this update is useful.

Thanks for the update. Yes, I’ve seen (and suggested) that NVIDIA-sepcific option before for ‘screen blanking’ and ‘brightness’ issues (related to some power state changing quirk of some nvidia graphics hardware). It’s important to note that you have to be using the proprietary nvidia driver (as opposed to the nv or nouveau drivers). Glad that it worked for you.