ThinkPad R61i volume keys

I use openSuSE 11 with KDE4 on ThinkPad R61i.
My problem is in my volume keys (increase, decrease, mute), they doesn’t work at all!
I have searched this forum and found an answer - pommed package. So I’ve installed pommed and the keys worked! but only until restart. What can be wrong? Please HELP!

here’s pommed output

# pommed -d
I: pommed v1.15 ($Rev: 434 $) Apple laptops hotkeys handler
I: Copyright (C) 2006-2008 Julien BLACHE <>
pommed configuration:

  • General settings:
    fnmode: 1
  • ATI X1600 backlight control:
    initial level: -1
    step: 10
    on_batt: 0
  • Intel GMA950 backlight control:
    initial level: 0xffffffff
    step: 0xf
    on_batt: 0x0
  • nVidia GeForce 8600M GT backlight control:
    initial level: -1
    step: 1
    on_batt: 0
  • Audio volume control:
    card: default
    initial volume: -1
    step: 10%
    beep: no
    volume element: PCM
    speaker element: Front
    headphones element: Headphone
  • Keyboard backlight control:
    default level: 100
    step: 10
    auto on threshold: 20
    auto off threshold: 40
    auto enable: no
    idle timer: 60s
  • CD eject:
    enabled: yes
    device: /dev/dvd
  • Beep:
    enabled: no
    beepfile: /usr/share/pommed/goutte.wav
  • Apple Remote IR Receiver:
    enabled: yes
    SMBIOS vendor name: [LENOVO]
    E: Unknown non-Apple machine

What are you saying? That you have to run pommed every restart?

If I want to use my volume keys on thikpad, I have to start pommed?? right?
Here’s the problem:
First time I’ve started pommed it worked.after restaring my laptop pommed won’t start anymore because of an error (see above)

Well, my volume keys on TP R61i worked out of the box on openSUSE 11.0. No need to install anything. The only thing I experienced was that the volume keys change the volume “different” than Kmix. I mean, the keys change PCM and Kmix changes the master channel, or vice versa.
Do you know xev? Type xev in a commandline, move your mouse over the little window that appears and then press a volume button. You will get a lot of output in your terminal, and somewhere there you will find sth that on my ms keyboard reads: “keycode 176 (keysym 0x1008ff13, XF86AudioRaiseVolume)”. As you see this is my Volume + button.
You can map any key to whatever you want using xmodmap. Syntax was similar to this, I think: xmodmap -e “keycode 123 = XF86AudioRaiseVolume”. If it works you can save these settings into a file which will be read in automatically everytime you login. See man xmodmap for details.

Oh, I forgot. With openSUSE11.0, the keys worked out of the box on KDE3.5 only, not with KDE4. Haven’t tried with openSUSE11.1 and KDE4 yet on my thinkpad, but on my Microsoft keyboard volume keys work…

Are you certain it was pommed that allowed your keys to work the first time, and not some other app?

Maybe by installing pommed you actually broke this?

It doesn’t work.
If I assign some letter to keymap code, the key writes the letters, but if I assing e.g. XF86AudioMute nothing happen???
That’s weird. Maybe I have to set up my keyboard???

Solved! :slight_smile:
In Configure Desktop > Keyboard & Mouse > Keyboard Shortcuts I have configured/set shortcuts to my keys.
It Work!

Thank You
And Here’s another one :slight_smile:
Fn+Home and Fn+End (brightness up/down) keys don’t work. :frowning:

for setting my brightness I use xbackligt --setXX command
I would be happy if I might be able to use keys.?Can you help me?