Thinkpad fancontrol

Hello, I’ve tried several hours but couldn’t make it work.

With recent ATI graphic card update, I have overheating problem when gaming. I watched the temperature curve and listened to the sound of the fan while gaming. Interestingly, the fan only goes to max speed at 90 degree(C), and is able to bring down the temperature immediately, but it is already too late.

Then I found lots of people having been solving this ATI related problem by all kinds of fancontrol program.

Results of my research:

These are the most useful. What I have used is the program “thinkfan”. I’ve found it on opensuse repositories and installed it. Then I followed the auchlinux instruction for T420 (mine being E420 but same structures). However in the end,

“Finally to enable systemd daemon thinkfan. sudo systemctl enable thinkfan” It shows "Failed to issue method call: No such file or directory.

There is a service named “fancontrol” in Yast-services management, but it couldn’t be started showing “ConditionFileNotEmpty=/etc/fancontrol was not met”.

~> sensors
Adapter: Virtual device
temp1:        +40.0°C  (crit = +120.0°C)

Adapter: ISA adapter
fan1:           0 RPM

Adapter: ISA adapter
Physical id 0:  +59.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +59.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +56.0°C  (high = +86.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +59.0°C  

 :~> cat /etc/modprobe.d/50-thinkpad.conf
sensor /sys/devices/virtual/thermal/thermal_zone1/temp
options thinkpad_acpi experimental=1 fan_control=1

 :~> cat /etc/modprobe.d/thinkpad_acpi.conf
sensor /sys/devices/virtual/thermal/thermal_zone0/temp
options thinkpad_acpi experimental=1 fan_control=1

 :/proc/acpi/ibm> cat fan
status:         enabled
speed:          0
level:          auto
commands:       level <level> (<level> is 0-7, auto, disengaged, full-speed)
commands:       enable, disable
commands:       watchdog <timeout> (<timeout> is 0 (off), 1-120 (seconds))