[ThinkPad E585] No WIFI For 5 Weeks (Gnome) KDE 2 Days Ryzen 2700U

Tumbleweed Gnome March 2019 Builds NO INTERNET

You did something wrong about a month ago on Gnome, because we rely on WIFI and the clean install must be deleted since then. Network stuff in services are all marked dead, enabling them end in a question mark icon.

Machine Firmware Bug: Ryzen 2700U Vega mobile x4

iommu=soft to boot in. Mok Manager (disable-validation) to keep secure boot (SB) enabled, to dual boot a second distro, to compile mainline Kernel and to see WIFI circuitry below Kernel 4.18. We have the same issue now, there is no Network on task bar after the fresh install.
This is Kernel 5.0.2 and we are looking for 5.1-rc’s. We did not try to wake-up WIFI with the offline RPM package of Kernel 5.1-rc1.

How to force WIFI after a fresh install of Tumbleweed? How to configure the dam card?!?

On other distros, mokutil --disable-validation appears to be the solution. Re-enabling it, disabling SB has no effect. Our very first problem with secure boot was on the arrival of 18.04.2 with the Grub updates (Feb.1st Ubuntu 18.04.x daily ISO after updates).
The machine was unusable with secure boot enabled on mainline Kernel: invalid signature(error1), you need to load the Kernel first(error2). Since then, Linux is a constant battle to win.

Tumbleweed WIFI is an unknown equation for now and Tumbleweed is the only distro that detects the secure boot issue, boots in MOK Manager and offers the solution. Which is to enroll both Key and hash in Grub x64 twice.

Ryzen 2nd gen is at best on mainline Kernel, Tumbleweed is among our best friends. Please fix it!

Try as root:

netconfig update -f

No effect even with Kernel 5.1-rc2 RPM package:

rpm -qa | grep -i kernel
xx@linux-p3r4:~> uname -r
xx@linux-p3r4:~> su -
linux-p3r4:~ # netconfig update -f
linux-p3r4:~ # exit
**nmcli device wifi**
Error: NetworkManager is not running

Error: NetworkManager is not running

So you do not switch to Network Manager ins Yast-----System----Network Settings------global Options-----Network Setup Method?

Will try that, Tumbleweed worked perfectly before. How Am I suppose to know that?

Edit: Getting an error when entering Window Boot Manager

Error: no shim lock protocol

Press any key to continue… Works!

Dead: Where is nm applet? How do I paste a screenshot?

First screenshot
YaST2/Applet needed
NetworkManager is controled by desktop applet(KDE plasma and nm-applet for Gnome).
Be sure it’s running and if not, start it manually.

Second screenshopt
Error: No network running.

Third screenshot
Warning /Network is currently handeled by NetworkManager or completly disabled. YaST is unable to configure some options.

How did you update TW? Should only be through ‘zypper dup’ as per documentation
Another thing: The kernel version you show is not TW’s. Please show

zypper lr -d

Title says that we have no Internet for 5 weeks now. The given command line shows Vanilla.

Suse Mainline Kernel Server:


[x] kernel-vanilla-5.1.rc2-2.1.g7da01f5.x86_64.rpm /63M/YaST_Offline_same for any other distros

Tumbleweed Daily ISO Server:

[x] openSUSE-Tumbleweed-DVD-x86_64-Current.iso /4.3G

zypper lr -d
# | Alias               | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                            
1 | openSUSE-20190325-0 | openSUSE-20190325-0         | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-Verbatim_TUFF_N_TINY_07073400D6443647-0:0-part1
2 | repo-debug          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                        
3 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | ( p) Yes  | Yes     |   99     | NONE   | http://download.opensuse.org/tumbleweed/repo/non-oss/                          
4 | repo-oss            | openSUSE-Tumbleweed-Oss     | Yes     | ( p) Yes  | Yes     |   99     | NONE   | http://download.opensuse.org/tumbleweed/repo/oss/                              
5 | repo-source         | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                       
6 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | ( p) Yes  | Yes     |   99     | NONE   | http://download.opensuse.org/update/tumbleweed/ 

It is the first time that mainline Kernel does not wake-up the WIFI network. The BIOS born date is Dec. 10th 2018 and we do not have wired network.
There is a long lasting bug here in Tumbleweed ISO’s. Trying to debug it alone since 5 weeks, the list of attempts is pretty long.

Where is nm-applet activation location?

The solution in Yast system under services manager:

  1. Network Manager = Start/on boot
  2. systemd-networkd = Start/manually

Force network in Yast>system>services manager>network manager>start>on boot>+>systemd-networkd>>start>manually. Apply changes.
The two services enable WIFI on taskbar. Restart to see if WIFI starts automatically on boot.

Before reporting any errors/bugs, remove the kernel repo, run ‘zypper dup’.

Windows Ten was detecting the boot error and I let it check disk to see what is going on. The error message was about bootmgfw.efi. After check disk, a 200MB partition was created before the main NTFS partition. I deleted the partition and resize C: drive to its original size.

Then, I went back to MOK Manager to enroll Microsoft key and hash in bootmgwf.efi and bootx64.efi. It didn’t work. The message was displayed again. Went back in MOK utility to re-enable validation:

sudo  mokutil  --enable-validation

The message is gone now and Windows Boot Manager boots normally without the error. Since mainline Kernel comes from repo, it is not an unsigned Kernel and there is no need to disable secure boot momentarily on startup. At least for Tumbleweed that comes with Kernel 5.0.

Will now double check the WIFI issue by deleting the Gnome installation and re-install it with KDE.

KDE fresh install without MOK Manager tweak. Mainline Kernel boots normally and the machine runs faster.

The tweak to keep existing Kernel and 3 others did not work:

leafpad /etc/zypp/zypp.conf

adding this : multiversion.kernels = latest,latest-1,latest-2,latest-3,running

below this:multiversion = provides:multiversion(kernel)

rpm -qa | grep -i kernel
mokutil  --sb-state
SecureBoot enabled

Tumbleweed KDE 20190327 build /The bug is also present in KDE

Prior to this, in Network Settings the network setup method must be set to << NetworkManager Service. Click OK after to apply changes.
An error will be shown: No Network Running, click OK. The WIFI Network will be shown on the taskbar. Then do the above for Network Manager and systemd.
The installer needs attention**. There is no setup configuration for WIFI, the r8169 driver is for Ethernet. WiFi driver not listed in the installer nor even after the fresh install:

Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter [10ec:b822]
    Subsystem: Lenovo Device [17aa:b024]
    Kernel driver in use: r8822be
    Kernel modules: r8822be

Thanks @ karlmistelberger for pointing out the systemd issue. In our previous attempts over the last month, we were trying to enabled too many services at the same time. Two of them need attention only.



Thanks for the feedback. Never thought the post would be helpful for others.