Thinkpad 600E: openSUSE 11.0 can't mount DVD on first boot

Trying to install openSUSE 11.0 on my old TP600E and the install seems to go OK (for the important bits), but on the first boot from the HD during the configuration phase, the DVD drive can’t be mounted. Searching on the Web, I find lots of folklore on how to fix this or similar problems, but none of the proposed fixes actually work; either nothing changes (acpi=off, pci=nomsi), or my HD goes away (libata.pata_dma=1). This is what shows up in boot.msg:

<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
<4>         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
<4>         res 40/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
<3>ata2.00: status: { DRDY }
<7>ata2: port disabled. ignoring.
<6>ata2: EH complete
<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
<4>         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
<4>         res 40/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
<3>ata2.00: status: { DRDY }
<7>ata2: port disabled. ignoring.
<6>ata2: EH complete
<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
<4>         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
<4>         res 40/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
<3>ata2.00: status: { DRDY }
<7>ata2: port disabled. ignoring.
<6>ata2: EH complete
<4>ata2.00: limiting speed to MWDMA1:PIO4
<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
<4>         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
<4>         res 40/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
<3>ata2.00: status: { DRDY }
<7>ata2: port disabled. ignoring.
<6>ata2: EH complete
<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
<4>         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
<4>         res 40/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
<3>ata2.00: status: { DRDY }
<7>ata2: port disabled. ignoring.
<6>ata2: EH complete
<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
<4>         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
<4>         res 40/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
<3>ata2.00: status: { DRDY }
<7>ata2: port disabled. ignoring.
<6>ata2: EH complete

Any suggestions?

Well, I found the answer. Entering the following magic phrase at boot time and adding it to Grub’s menu.lst, everything can be made to work:

apm=on acpi=off pnpbios=off