Things I learned setting up a triple boot system

I’m posting this thread in the hopes it might help someone else.

I had a dual boot system openSUSE 13.1 and Fedora 20 running on three drives.

Drive #1 was an SSD that contained the root of the openSUSE system
Drive #2 was a mechanical drive that contained /home, /tmp and /var of the openSUSE system.
Drive #3 was a mechanical drive that contained the entire Fedora system.

The Fedora system was in place for the express purpose of running Netflix on linux.

I decided I just couldn’t throw rocks at Windows unless I had a Windows system to run so I could find all the warts and weaknesses. So, I purchased a copy of Windows 8.1 Pro. I am very distrustful of having two operating systems on the same drive, therefore I drug out a new drive for the Windows install. I’m going to say right now, that I may have done a few things the hard way, and if someone has a better or another way of doing what I did, I’d be glad to hear it.

Windows requires that it be installed on the first drive in a system. That meant I had to move drive #3 to position #4, drive #2 to position #3, drive #1 to position #2 and install the new drive as drive #1. The usual procedure is to install Windows first, but I already had linux installed, and the most important thing at this point was to get openSUSE up and running in it’s new location. I wanted to be sure the new drive was recognized as being there while I did this, so I installed it as drive # 4 and, using gparted created a partition table and the pertitions I wanted. (If you do this, be aware that Windows wants a MBR table and will not install to a GPT formatted drive.) The fstab file on my openSUSE system has the drives listed as drive-by-path, so I opened the file as root and modified it to reflect the new paths. I then shut down the system, installed the new blank drive in the number 1 spot, and moved the rest down. openSUSE was up and running at this point! lol!

Next, I tried to get Fedora up. I modified fstab and tried, I did a few other things I had to undo, but soon lost interest and decided it was time to upgrade it to Fedora 21 anyway. I downloaded F-21 and burned a DVD. Then went on the Windows.

Now, I shut down and pulled the cables from all the drives but the one that was to hold Windows, drive #1. Put in the DVD, fired up the computer, and did the install. It was uneventful and soon I could boot to Windows.

I downed the machine again, and did the install of Fedora 21 to drive # 4. Again, and uneventful install. Fedora was up and running!

Almost unbelievably to me, if I just powered up my machine, I got my old grub boot menu and openSUSE would come up perfectly. I opened konsole, su’d to root, and did

grub2-mkconfig -o /boot/grub2/grub.cfg

And the rest is history! I now have 5 choices on my grub menu: openSUSE, Advanced openSUSE, Windows, Fedora 21, and Advanced Fedora21. And they work.

I guess it couldn’t have been too much easier.
Things I learned:

  • The mkinit log file contained a reference to the old path to the openSUSE drive. I didn’t change that, I didn’t run mkinitrd. It just worked and I’m not sure why.
  • Fedora is not openSUSE. The changes I made to openSUSE did not work on Fedora. Maybe I should have spent more time on finding out why, but I didn’t.
  • Windows is still Windows. Just like NT, Win2K and XP, put it on it’s own drive, pull the cables on everything else, and it’ll install just fine.

Bart

On 2015-01-28, montana suse user <montana_suse_user@no-mx.forums.opensuse.org> wrote:
> I’m posting this thread in the hopes it might help someone else.

Thanks for posting and sharing your experiences. It might be helpful to some when interpretating your story if you could
list your computer system specification (in particular whether your motherboard adopts BIOS or UEFI).

> Windows requires that it be installed on the first drive in a system.

That must be a particular requirement for your Windows installer, because all versions of Windows I’ve used alongside
GNU/Linux (from 2000->8), allows installation in any order. In general however, I’d agree it’s often more convenient to
install Windows first.

> (-If you do this, be aware that Windows
> wants a MBR table and will not install to a GPT formatted drive.-)

I have Windows 8 installed onto a GPT formated drive but I believe this can only happen with UEFI booting.

> Code:
> --------------------
> grub2-mkconfig -o /boot/grub2/grub.cfg
> --------------------

This command strongly indicates you’re not booting with UEFI which is probably why your Windows won’t install onto a GPT
drive.

> - Windows is still Windows. Just like NT, Win2K and XP, put it on
> it’s own drive, pull the cables on everything else, and it’ll install
> just fine.

This may be a motherboard-specific issue, but in general most BIOS configurations allow you to choose the boot-priority
for individual hard drives. This way I don’t have to pull out cables. I prefer not to pull out the cables because that
way I can be more confident about correct and consistent /dev/sda, /dev/sdb etc… ordering. One of my boxes has a
quad-boot on four separate drives (openSUSE, Win7, Gentoo, Mint), where consistent device assignment is very helpful.

Good point. Thanks for your comments! I’m using an ASUS Sabertooth 990FX motherboard that supports UEFI. That said, there seems to be some serious differences in the implementation of BIOS’s from different manufacturers. I have found that this board seems to have some ah… weirdnesses (is that a word?).

> Windows requires that it be installed on the first drive in a system.

That must be a particular requirement for your Windows installer, because all versions of Windows I’ve used alongside
GNU/Linux (from 2000->8), allows installation in any order. In general however, I’d agree it’s often more convenient to
install Windows first.

I got this fact from several different sources on several different forums. I didn’t check it myself, it certainly may be board dependent or just user impression. Seems I’m guilty of propagating a non-fact. Would have saved me a ton of work! You know, I’m wondering about this. Are you saying that if I had, for instance, four blank drives in my machine, Windows would have given me the choice of which one to use? I don’t know, I’ve never tried it.

> (-If you do this, be aware that Windows
> wants a MBR table and will not install to a GPT formatted drive.-)

I have Windows 8 installed onto a GPT formated drive but I believe this can only happen with UEFI booting.

I started the Windows install by entering the BIOS and selecting the UEFI labeled DVD drive containing the Windows install disk. If that didn’t start it using UEFI, then I would consider that a thing I could throw rocks at! Just what I’m looking for! :slight_smile: Actually though, as it’s on its own drive, it doesn’t really matter. At least to me.

> Code:
> --------------------
> grub2-mkconfig -o /boot/grub2/grub.cfg
> --------------------

This command strongly indicates you’re not booting with UEFI which is probably why your Windows won’t install onto a GPT
drive.

I don’t quite understand this comment. I know for a fact that openSUSE is using UEFI, and I’m using the openSUSE version of grub2 and it needs this command to be run to make the menu show what’s actually availible

> - Windows is still Windows. Just like NT, Win2K and XP, put it on
> it’s own drive, pull the cables on everything else, and it’ll install
> just fine.

This may be a motherboard-specific issue, but in general most BIOS configurations allow you to choose the boot-priority
for individual hard drives. This way I don’t have to pull out cables. I prefer not to pull out the cables because that
way I can be more confident about correct and consistent /dev/sda, /dev/sdb etc… ordering. One of my boxes has a
quad-boot on four separate drives (openSUSE, Win7, Gentoo, Mint), where consistent device assignment is very helpful.

You are correct about being able to choose boot boot-priority. But, I do not trust Windows! When I install a copy of Windows, I want the drive on which it will reside to be the only drive available. Windows cannot trash a non-windows drive it it’s not hooked up! I learned this back in the Windows NT / OS2 days. I have found there to be a consistant assignment correlating to the motherboard connections. Yes. if I connect only one drive to the third connector, it’ll be sda. But if I connect four drives to four of the SATA connectors, they will reliably be numbered. That’s why I installed the blank Windows drive in the system while I reconfigured the Linux systems.
Case in point, when I started Windows, it showed the other linux drives as being assigned drive letters. But when I “clicked” on them, thinking Windows had possibly decided to recognize ext4 drives, Windows promptly told me they weren’t formatted and offered to do so for me!

Thanks again for your input. You’ve given me some things to think about. And that’s a good thing!

Bart

On 2015-01-28 13:16, montana suse user wrote:
>
> flymail;2691705 Wrote:

> I got this fact from several different sources on several different
> forums. I didn’t check it myself, it certainly may be board dependent
> or just user impression. Seems I’m guilty of propagating a non-fact.
> Would have saved me a ton of work! You know, I’m wondering about this.
> Are you saying that if I had, for instance, four blank drives in my
> machine, Windows would have given me the choice of which one to use? I
> don’t know, I’ve never tried it.

Indeed, you can choose disk and partition - unless you are using an OEM
disk, which may come prepared for certain kind of installation, not a
generic one.

But with older windows versions it was harder.

> You are correct about being able to choose boot boot-priority. But, I
> do not trust Windows! When I install a copy of Windows, I want the
> drive on which it will reside to be the only drive available. Windows
> cannot trash a non-windows drive it it’s not hooked up!

I tend to agree. I temporarily installed windows for a test on my
computer, and I unplugged everything (disks). After it was installed, I
reconnected the rest, and the bios lets me choose which drive boots.

With everything removed there is no chance of Windows mistaking where to
install or what to do :wink:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I didn’t know that! Obviously! Count that day lost …

The Windows installation is working great. The Fedora install, not so much. I may just make another try at it.

> You are correct about being able to choose boot boot-priority. But, I
> do not trust Windows! When I install a copy of Windows, I want the
> drive on which it will reside to be the only drive available. Windows
> cannot trash a non-windows drive it it’s not hooked up!

I tend to agree. I temporarily installed windows for a test on my
computer, and I unplugged everything (disks). After it was installed, I
reconnected the rest, and the bios lets me choose which drive boots.

With everything removed there is no chance of Windows mistaking where to
install or what to do :wink:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

But then, you and I suffer from paranoia! :wink:

Bart

Hi
If you pre-configure the drive there are no issues using the custom option to install windows on the partition of your choice. If your booting UEFI with => windows 7 then just need an msr (128MB) partition as well. I have never done windows after a linux install. If I did would backup the /boot/efi data first.

Never had an issue with openSUSE adding in any other operating systems with multiboot, check that YaST bootloader has the os-prober checked before moving on with the install.

ASUS and SATA ports, yes, my old ASUS board changes them depending on how many drives are plugged in, but at least can choose the boot order… though it was a headache initially when setting up RAID10 and ensuring drives are across the two different controllers so if one fails the RAID will degrade but still work.

On 2015-01-28, montana suse user <montana_suse_user@no-mx.forums.opensuse.org> wrote:
> I have found that this board seems to have some ah…
> weirdnesses (is that a word?).

Whether weirdnesses' is a word depends on if weirdness’ countable or not. I’m not sure to be honest. Try
`peculiarities’ :).

Are you saying that if I had, for instance, four blank drives in my
machine, Windows would have given me the choice of which one to use? I
don’t know, I’ve never tried it.

Depends. OEM Windows versions often have a their own peculiarities (:D) that can restrict your freedom. Retail versions
post-XP are otherwise flexible.

This command strongly indicates you’re not booting with UEFI which is
probably why your Windows won’t install onto a GPT
drive.

I don’t quite understand this comment. I know for a fact
that openSUSE is using UEFI, and I’m using the openSUSE version of grub2
and it needs this command to be run to make the menu show what’s
actually availible

You sure? The only reason why I’m uncertain whether you really are is that your grub-mkconfig command seems to output to
/boot/ rather than /boot/efi. Does the following command result in an error?


sh-4.2$ su -c "modprobe efivars"

… if so, you’re booting in legacy BIOS mode.

> You are correct about being able to choose boot boot-priority. But, I
> do not trust Windows! When I install a copy of Windows, I want the
> drive on which it will reside to be the only drive available. Windows
> cannot trash a non-windows drive it it’s not hooked up!

You don’t need to unplug the cables to disable individual drives. In the BIOS, you can simply disable the SATA adaptor
motherboard-side for the relevant drive(s) independently. I admit sometimes to doing this when installing Windows in order to
guarantee the installer writes the MBR record to the correct drive.

On 2015-01-28, montana suse user <montana_suse_user@no-mx.forums.opensuse.org> wrote:
> I have found that this board seems to have some ah…
> weirdnesses (is that a word?).

Whether weirdnesses' is a word depends on if weirdness’ countable or not. I’m not sure to be honest. Try
`peculiarities’ :).

Are you saying that if I had, for instance, four blank drives in my
machine, Windows would have given me the choice of which one to use? I
don’t know, I’ve never tried it.

Depends. OEM Windows versions often have a their own peculiarities (:D) that can restrict your freedom. Retail versions
post-XP are otherwise flexible.

This command strongly indicates you’re not booting with UEFI which is
probably why your Windows won’t install onto a GPT
drive.

I don’t quite understand this comment. I know for a fact
that openSUSE is using UEFI, and I’m using the openSUSE version of grub2
and it needs this command to be run to make the menu show what’s
actually availible

You sure? The only reason why I’m uncertain whether you really are is that your grub-mkconfig command seems to output to
/boot/ rather than /boot/efi. Does the following command result in an error?


sh-4.2$ ls /boot/efi/

… if so, you’re booting in legacy BIOS mode.

> You are correct about being able to choose boot boot-priority. But, I
> do not trust Windows! When I install a copy of Windows, I want the
> drive on which it will reside to be the only drive available. Windows
> cannot trash a non-windows drive it it’s not hooked up!

You don’t need to unplug the cables to disable individual drives. In the BIOS, you can simply disable the SATA adaptor
motherboard-side for the relevant drive(s) independently. I admit to disabling SATA ports sometimes when installing
Windows in order to guarantee the installer writes the MBR record to the correct drive.

On 2015-01-28 17:44, flymail wrote:

> You don’t need to unplug the cables to disable individual drives. In the BIOS, you can simply disable the SATA adaptor
> motherboard-side for the relevant drive(s) independently. I admit to disabling SATA ports sometimes when installing
> Windows in order to guarantee the installer writes the MBR record to the correct drive.

Mmm. Interesting idea. I have never tried this, but it will depend on
what options the bios offers, how to use them, and whether they work.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

The Windows copy I purchased is a retail version, not an OEM. I actually called MIcrosoft to verify that I had the legal right to move this copy to another machine if I choose.

>> This command strongly indicates you’re not booting with UEFI which is
>> probably why your Windows won’t install onto a GPT
>> drive.
>>

> I don’t quite understand this comment. I know for a fact
> that openSUSE is using UEFI, and I’m using the openSUSE version of grub2
> and it needs this command to be run to make the menu show what’s
> actually availible

You sure? The only reason why I’m uncertain whether you really are is that your grub-mkconfig command seems to output to
/boot/ rather than /boot/efi. Does the following command result in an error?

sh-4.2$ ls /boot/efi/

… if so, you’re booting in legacy BIOS mode.

bart@UNIVAC:~> ls /boot/efi/
EFI  $RECYCLE.BIN  System Volume Information
bart@UNIVAC:~>

Now, this is, of course, on the openSUSE drive. The Windows drive will have it’s own copy as it was the only drive in the machine at the time of installation.

You don’t need to unplug the cables to disable individual drives. In the BIOS, you can simply disable the SATA adaptor
motherboard-side for the relevant drive(s) independently. I admit to disabling SATA ports sometimes when installing
Windows in order to guarantee the installer writes the MBR record to the correct drive.

Now, that got me to wondering if I had missed something. With this version of an ASUS modified AMI BIOS, I can disable SATA ports 1-4 and/or ports 5-6, but not individual ports. So, off come the cables!

Today, I noticed that the Fedora install is not using UEFI. It works, it boots from the openSUSE version of grub2, but I’m thinking I’ll reinstall it, using UEFI and force it to go on it’s own drive. That way I should be able to choose the boot drive from the bios screen, and have a grub2 menu appear allowing me to boot any of the systems just like I can do from the openSUSE drive. Except from the Windows drive of course.

I’m using UEFI. And, to update grub.cfg, I use:

# grub2-mkconfig -o /boot/grub2/grub.cfg

Does the following command result in an error?

sh-4.2$ ls /boot/efi/

… if so, you’re booting in legacy BIOS mode.

A better test is

# efibootmgr -v

which will return an error if not booted to EFI.

Or try (no need for root)

bootctl status

(maybe that’s new to 13.2). It won’t give an error, but it will give output that indicates how you booted.

Thanks for the very useful information nrickert.

On 2015-01-29, nrickert <nrickert@no-mx.forums.opensuse.org> wrote:
> I’m using UEFI. And, to update grub.cfg, I use:
>
> Code:
> --------------------
> # grub2-mkconfig -o /boot/grub2/grub.cfg
> --------------------

Ah interesting! My only UEFI desktop couldn’t load the openSUSE 13.2 installer in UEFI mode (can’t seem to find how the
kernel parameters can be changed to safe-settings) so I had to install it with BIOS legacy. I have another distro I
could install in UEFI-mode manually (nightmare!), mounting the vfat partition as /boot/efi, so when I update grub or the
kernel, I invoke…


sh-4.2# grub2-mkconfig -o /boot/efi/EFI/GRUB/grub.cfg

… but it seems openSUSE does things differently.

A better test is

Code:

# efibootmgr -v

I agree! More generally, however, it is possible to boot into GNU/Linux in UEFI mode without efibootmgr installed. When
I have, the only way I’ve been confident I’ve booted into UEFI is using:


sh-4.2$ ls /sys/firmware/efi/vars/

> Or try (no need for root)
>
> Code:
> --------------------
> bootctl status
> --------------------

Interesting. This looks to be a systemd command. Learn something new every day. Thanks!

And will return nothing if not root! Just no response at all, just the prompt.

Or try (no need for root)

bootctl status

(maybe that’s new to 13.2). It won’t give an error, but it will give output that indicates how you booted.

Nope. Works in 13.1

A word of warning, avoid at all cost mixing EFI and traditional MBR booting. It can lead to interesting problems. Not all BIOS properly support the mixed mode even if they say they do.

Perhaps an overstatement.

Mixing modes is a problem with Windows. But not so much for opensuse.

Example: I have both Tumbleweed (EFI) and 13.2 (MBR) installed on one box. But I use the EFI grub menu to boot either. I deliberately used an MBR install for the second of those, so as simplify the managing of NVRAM entries for EFI booting.

Seen lots of problems here with people mixing modes. ie having a a EFI install then installing openSUS as MBR. It seems to always end in tears. Mixing in the old MBR/DOS format and GPT and you have a witches brew. Can it be done?? Sure, but you better know what you are doing and understand the basics of each method. Best to avoid it in entirely and install all using the same methods. Some BIOS say that they support mixed modes but the problem is more with the OS’s seeing mixed signals. Even So some specs on some BIOS just are not up to it either. So “Never mix never worry” (Who’s afraid of Virginia Wolf)

Wait, wait, wait! Are you talking about on the same drive or on separate drives? I made a mistake and installed Fedora as MBR, while openSUSE was EFI and Windows was EFI. They were all on their own disks though. Everything “seemed” to work just fine,

Separate disks should be ok the problem is mixing them on the same drive

I rather thought so.

the problem is mixing them on the same drive

:open_mouth: Who would do that?

rotfl!

Unfortunately people do do that.