"There was a problem with this video" && Enlightenment "setfreq" utility issues??


So I’ve got Gecko MATE LEAP 42.2 installed in one partition, and the full-zoot LEAP 42.2 GNOME pattern in another . . . when I use the Gecko version I can play videos that are posted in FB; but, over in GNOME I get the “there was a problem with this video” error window . . . this is both in FF. I checked the “add-ons” and so forth in FF, and in GNOME nothing like “flashplayer” shows up . . . only apps to “download” and then play . . . .

I searched Yast to see if I could add “adobe-flashplugin” . . . which I saw in a recent “dist-upgrade” in another partition running plain-jane ubuntu-MATE 16.04 . . . . Yast found “no results” . . . and I tried “flashplayer” . . . also “no results.” Over in ubun-MATE the FB posted videos play OK . . . . Any chance to get FF set up to be able to play FB videos?

And, then, after getting some hints in another thread about installing “patterns” instead of “DE’s” . . . I used Yast to install “Enlightenment” pattern, and on log in lately there has been a “check cpufreq” using “setfreq utility” . . . the error shows a “sudo chmod” command . . . which is somewhat beyond my skillset . . . I found that zypper offers a “dist-upgrade” command, which I assumed to be like the “apt-get dist-upgrade” command from the general ubuntu world I’m used to . . . I ran that command in all of my OpenSUSE distros . . . didn’t seem to make any difference to the “cpufreq” applet . . . the only concern is that the what I think is the “CPU” applet will show intermittent “spikes” on the cpu . . . which, since Gecko doesn’t have that item on the default toolbar . . . I don’t know whether Enlightenment is “too high vibration” for my '12 Mac Pro’s cpu and it’s doing something that is causing a problem . . . or, it’s just a finicky applet trying to get attention where none is warranted??

Appreciate the thoughts as usual,


flash is propitiatory software and opensuse does not carry it
you can get it from the packman repo (recommended) or manually from adobe (adobe does not provide the public pgp key for it’s rpm’s and you will get a warning when installing, as you won’t have the pgp key packages from adpbe’s repo will not be auto updated you’d need to manually install when there is an update)
it seams you don’t have packman (flash didn’t appear in a yast search) add it, then do a vendor change to it and pull flash from it

zypper ar -f ftp://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.2/ packman
zypper dup --from packman
zypper in flash-player

I can’t understand what you are asking in the 2nd part as you’re asking something about Enlightenment and zypper and quoting ubuntu apps?
zypper dup (distribution upgrade) is used to change repo’s or upgrade your OS without reinstalling for example 42.1 to 42.2 you’d need to change your repo’s to point to 42.2 packages and run zypper dup or to do a full vendor change from the OSS (patent free open source only) repo to packman you’d do zypper dup --from packman try

man zypper


Thanks for the details on the flash install . . . I’ll check into it later. The question about the Enlightenment applet were around the log in error about a “cpufreq” problem with the “setfreq utility” . . . and it was showing some commands to perhaps run, but they were a “sudo” command, which wouldn’t apply to the OpenSUSE command style. My question is whether this applet is “finding a problem” or is “making a problem”?? I don’t get this error when logging into the GNOME pattern, or when I boot into Gecko MATE . . . or in Ubuntu-MATE . . . but, then they don’t have the applet.

But, since I used Yast to install the Enlightenment pattern, in other words, nothing else added beyond stock . . . why would there be this error? I just used what I thought would be a command to upgrade any and all packages to the latest to see if that would resolve the “cpufreq” error . . . but, it didn’t. And, question is whether it is something to be concerned about, as the little cpu “clock” spikes its reading, or, it’s nothing . . . or, best to remove the applet ??? Any of those questions . . . .


afaik sudo works fine with opensuse?
the only difference with some debian based distro’s is that on opensuse sudo does not allow for gui apps nether does su for that you’d use kdesu (or gnomesu)
I tried Enlightenment a few versions ago it kept crashing so I gave up
I can add applets/themes to plasma 5 from the internet without root access
you do not and should not need root access to configure a user desktop all config files are in your home and extra applets would go in your home, using sudo would only break file permissions
maybe an Enlightenment user can be of more help


Alrighty, thanks for the reply . . . as far as I know OpenSUSE “errors” the “sudo” command . . . and I believe I tried to “zypper” something using just “zypper” and it did nothing??? Whereas over in ubuntu all commands are prefaced with “sudo” . . . and that isn’t as “root” . . . .

Still only a few months into the OpenSUSE experience . . . I’m with you on the Enlightenment pattern, a somewhat “splashy” visual experience; still I’m wondering why I get an immediate “error” on the “cpufreq” applet when I log in . . . so, yes, if there are any Enlightenment gurus on board, perhaps a comment about it?


Well sudo is root. Difference is that on Ubuntu there is no normal root user set and the first user has permission to use sudo. BTW you can set user permissions in the sudo config files it just is not default. The Ubuntu way is considered a security problem since if someone has your account he also as all the system.

openSUSE is open source only (thus the name) Gecko includes non-open binaries in the install openSUSE does not. So if you want to use proprietary codecs or need proprietary drivers you need to install most are available on packman


OK, thanks for the post . . . I’ll have to check into the repos for packman . . . .