There is no transition button in Windows 10

Windows is on my first ssd drive. I installed openSUSE along with Hyprland on a clean ssd drive. The button to switch to the Windows system is missing from the initial boot menu of grub. How do I add this button?

@Hippoid Hi and welcome to the Forum :smile:
If you fire up YaST Bootloader and ensure on the Bootloader Options tab that the “Probe Foreign OS” box is checked and hit ok.


There is no Windows anyway. What else can I do?

Boot into Tumbleweed, then fire up YaST as @malcolmlewis said, select the Bootloader option, and make sure “Probe Foreign OS” is checked, hit OK and save everything and exit YaST.

1 Like

be sure fast boot is disabled in Windows otherwise Windows is not seen by Linux.

It didn’t help

@Hippoid As root user run the command os-prober and post the output.

To install openSUSE Tumbleweed, I downloaded the system to an MBR flash drive. Could this be the reason why grub is not finding windows 10?

@Hippoid sudo is not root user, su - then os-prober also efibootmgr and lsblk

image

@Hippoid Windows is installed as UEFI, you have installed openSUSE in Legacy boot…

OK, I’ll reinstall the OS. Thanks!

@Hippoid make sure you wipe all the partitions off sdb… if you don’t want to share the windows UEFI (sdc1) then disconnect the drive… you need to make sure when you install that you select your system BIOS boot AND that you use the UEFI boot…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.