The wondeful "Destination Host Unreachable" error

I have installed OpenSUSE 11.2 on an ECS GF8200A motherboard. The installation went fine; in fact, it was able to connect to the internet to check and download updates during the installation process.

However, since the first reboot after the installation steps were completed, the OpenSUSE system cannot reach anything other than its own IP addresses (localhost on lo, static IP address on eth0, and br0 IP address). This is very strange, especially since the br0 is able to get a DHCP address from the router - but no other machine on my network can ping either the static IP address on eth0 or the DHCP address on br0.

I have search all over the internet for things to check. ifconfig and ethtool do not indicate any problems, they are reporting IP addresses and details on the card fine. I do not have any firewall enabled. The route information returns just what I expect. The lights on the system and on the switch are normal, I’ve used various cables and ports on the switch to eliminate that as an issue.

I ran a wireshark trace on another system (at IP address that I had the OpenSUSE system (at try to ping. While the ping was returning the “Destination Host Unreachable” message on OpenSUSE, The wireshark trace shows that the system is sending an ARP broadcast looking for who has IP, and the system is responding with an ARP message containing its MAC and IP address to the OpenSUSE system. But somehow the OpenSUSE system does not see that.

Running arp -a on the pinged system shows the OpenSUSE system IP and MAC address, but interestingly, arp -a on the OpenSUSE system only shows the following: at <incomplete> on eth0 is the default gateway defined on the openSUSE system.

So I see that the OpenSUSE system is able to send information out to the network, and when I run the ping command on it, it is sending ARP broadcasts looking for the IP address, but for some reason is not able to receive the response the target system is returning.

What might be running on the OpenSUSE system to cause this? The tx and rx counts are changing on the ifconfig command output for eth0. I can only think of the firewall, but I disabled it during the install, yast2 confirms it is disabled, and iptables -L doesn’t show any rules. I must be missing something obvious, but I have run out of ideas. Any guidance or pointers to info would be appreciated- again I have does tons of Google searches and checked everything I found, but have run out of ideas. Thanks!

Broken NIC or driver perhaps.

Incidentally it’s always possible to ping one’s one IP address since that never goes out on the wire but is looped back internally so that’s not a reliable test of connectivity.

I know the NIC is fine, Ihave booted with boot repair disks and they connect to the network fine. If the driver was a problem I’m puzzled why it was able to go online and get updates during the installation, and also get a DHCP address for the br0 interface. The ethtool output shows the correct link speed and that the link is active.

The GF8200A uses a fairly standard built in NIC, I have Fedora running on another system with the same motherboard and there are no issues. I guess I can try reinstalling from scratch again but I’m hoping it is something fairly obvious.

You mention br0, which seems to indicate you have a bridge interface active. This is not the default setup. How come you have a br0?

Indeed. Sounds to me like it was installed in a VM.

I’m going to be running kvm that is why the br0 is there. I have figured out the problem - installing kvm caused br0 to be generated and eth0 to be bridge to it, but eth0 remained configured with an IP address and that caused the conflict. After going in yast2 and unconfiguring eth0, the system can access the network now via the br0 IP address.