The VM graphics console does not work - Error: NoneType' object has no attribute 'change_run_text'

Hi all, the first occurrence this issue was a few weeks ago. After rebooting or relogging to GDM, everythings is working fine. I can use the VM dubleclicking on VM in Virtual Machine Manager, resize the VM screen, etc. BUT, only a once time :. If I close the screen (without shutdown of the machine) and doubleclick again, I can see this:

Error launching details: 'NoneType' object has no attribute 'change_run_text'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/", line 837, in _show_vm_helper
  File "/usr/share/virt-manager/virtManager/", line 653, in show
  File "/usr/share/virt-manager/virtManager/", line 1316, in refresh_vm_state
  File "/usr/share/virt-manager/virtManager/", line 1299, in change_run_text
AttributeError: 'NoneType' object has no attribute 'change_run_text'

I am running Linux opensuse 4.14.4-1-default #1 SMP PREEMPT after DUP.


I assume you’re describing your Guest.

You should

  • Post which virtualization you’re using, and possibly verify you are using libvirt (virt manager) to manage your virtual machines
  • Post your HostOS
  • Verify your GuestOS
  • Since you suggest that your DM may be a factor, you should post your Guest Desktop.
  • Verify that you have upgraded your TW and if any other OS is in the picture as your HostOS(or GuestOS), that you’ve updated that as well.
  • Verify you are connecting to a local instance of virtualization (GuestOS is on the HostOS) and not connecting remotely to Guests on a remote machine… And, if you’re connecting remotely what network protocol you are using.


**Everything is okay now.
**I waited about two weeks for a fix before reporting. But, after the last upgrade, it’s ok. Already from the beginning (about a year) after the installation, the virtual screen freezes. It was always possible to quit and let the virt-manager go again to open screen of VM. Freezing the screen will be solved in a new thread, probably.

Regarding your questions / comments:
I run the TW (host) on my laptop and under KVM I run Windows 10 as a guest system. Everything i do over Virtual Machine Manager 1.4.3.
Tumbleweed Linux opensuse 4.14.4-1-default #1 SMP PREEMPT Tue Dec 5 14:58:24 UTC 2017 (b29439c) x86_64 x86_64 x86_64 GNU/Linux